summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-01-02 07:42:17 +0100
committerHans de Graaff <graaff@gentoo.org>2016-01-02 07:42:53 +0100
commit7b6fa4c3e756d77541dbbb6ca5959caed510d4f9 (patch)
tree1213844b8ff7ed5df5cbda0d44bf71c7594d8a61
parentdev-ruby/unf: cleanup (diff)
downloadgentoo-7b6fa4c3e756d77541dbbb6ca5959caed510d4f9.tar.gz
gentoo-7b6fa4c3e756d77541dbbb6ca5959caed510d4f9.tar.bz2
gentoo-7b6fa4c3e756d77541dbbb6ca5959caed510d4f9.zip
dev-ruby/httpclient: add 2.7.1
Package-Manager: portage-2.2.24
-rw-r--r--dev-ruby/httpclient/Manifest1
-rw-r--r--dev-ruby/httpclient/httpclient-2.7.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-ruby/httpclient/Manifest b/dev-ruby/httpclient/Manifest
index 1254651ff1b6..18667b883b7a 100644
--- a/dev-ruby/httpclient/Manifest
+++ b/dev-ruby/httpclient/Manifest
@@ -1,2 +1,3 @@
DIST httpclient-2.6.0.1.tgz 305847 SHA256 213f55639b85edf47fb32f865b59085a76d77c87355e9e13e747250f8da0f6e9 SHA512 bcb71a7b6be7d132df63c5434cb2d4be46fa9b5c585b68a8a8269e46acecde6403098555e219354c60fc193016651c1bda53bffd9d509a517a3104c9a4e04efe WHIRLPOOL 4ded5d0b5f93c3b58df1e1c2233ae3a6219d797c0fb193d4995a2863fda76bad10ef0429f79a01c9b3c7c9ae27e20879b81db34239ff901a502baea9d6436785
DIST httpclient-2.7.0.1.tgz 456279 SHA256 734b885ab5310ff2da7a2f90c14f899f3884b1194db1dcb7da46d9277d8222e0 SHA512 f7be24dd59427578b665702cb5b33916caf4cc3d8eeca52e11f91e27f0e676b52056485dcf72284fed4f2db2eac3ed6654afb87f6f8a4580c1b8a59bf3ce2ee4 WHIRLPOOL 6025e4041df5bf78eb1574c5e11c7a49c809ad4aee74d08b1b35318cfc7d4481054de8be0a3efb68fb6273899c3a730e3541f96c3a70c93a740f256e58359752
+DIST httpclient-2.7.1.tgz 457036 SHA256 d176c5177745d60434a05c3d85497f9a56c725aa6f9ee98ac14349f9ffe05cfc SHA512 960770fe351a82e4008ca706bc0f1c7ba255b67dcbcc2984b1f76b78bdb9236b799dbd81c98d706a6a3755677b8d11fe7d7dd5b3af6afaaf901d70d999a09ea2 WHIRLPOOL d6c70683f702c2b749d56ff011beb24e8b4d77acab6f587986e44ecd6a3c6ac73059b4080715b97b750d773c1c13bf4abcb91a0748087e233b0509b2592daa1d
diff --git a/dev-ruby/httpclient/httpclient-2.7.1.ebuild b/dev-ruby/httpclient/httpclient-2.7.1.ebuild
new file mode 100644
index 000000000000..25cf2f3ace0d
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.7.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httpclient.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/http-cookie )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[bB]undler/s:^:#:' Rakefile || die
+
+ # Fix documentation task
+ sed -i -e 's/README.txt/README.md/' Rakefile || die
+
+ # Remove mandatory CI reports since we don't need this for testing.
+ sed -i -e '/reporter/s:^:#:' Rakefile || die
+
+ # Remove mandatory simplecov dependency
+ sed -i -e '/[Ss]imple[Cc]ov/ s:^:#:' test/helper.rb || die
+
+ # Comment out test requiring network access that makes assumptions
+ # about the environment, bug 395155
+ sed -i -e '/test_async_error/,/^ end/ s:^:#:' test/test_httpclient.rb || die
+
+ # Skip tests using rack-ntlm which is not packaged. Weirdly these
+ # only fail on jruby.
+ rm test/test_auth.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'gem "test-unit"; Dir["test/test_*.rb"].each{|f| require f}' || die
+}