summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-31 09:19:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-03-31 12:14:22 +0200
commit7b7935a02e19912b5f47563911d55d51a613d669 (patch)
tree0bcfcecf4b440b0e9feff02633e0cec1e55851d8
parentdev-python/django-rq: Bump to 2.4.1 (diff)
downloadgentoo-7b7935a02e19912b5f47563911d55d51a613d669.tar.gz
gentoo-7b7935a02e19912b5f47563911d55d51a613d669.tar.bz2
gentoo-7b7935a02e19912b5f47563911d55d51a613d669.zip
dev-python/sqlalchemy: Bump to 1.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlalchemy/Manifest1
-rw-r--r--dev-python/sqlalchemy/sqlalchemy-1.4.4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/sqlalchemy/Manifest b/dev-python/sqlalchemy/Manifest
index 2297389173c3..99710ff4dab6 100644
--- a/dev-python/sqlalchemy/Manifest
+++ b/dev-python/sqlalchemy/Manifest
@@ -7,3 +7,4 @@ DIST SQLAlchemy-1.4.0.tar.gz 7440276 BLAKE2B dce64f2a5fe2b67be2a6d79680a77460300
DIST SQLAlchemy-1.4.1.tar.gz 7450731 BLAKE2B 9868347a3ccc3519fe31cfca41f318d0b0832aa301c7c91a073fd877f5c29289aa91008feb31096a62a939e70eded88ee21bfc586d09f68ebff4f48ef4e50c8e SHA512 8d2f84aa7edfec65a1f2286210c8728c39f1411da1b0cb6f60cf6345fc692646ae4f2a062b2e4b2f04fe9000678d682c939645f7affbe518821299ae129e8ea8
DIST SQLAlchemy-1.4.2.tar.gz 7464092 BLAKE2B dd4cf617a66ed4eba54e41ebaead189409e09e434bdfe8e6f71e2fd4bd9ea574acef8feb42290a3fe80f602d2de2160b075633449b0b543e44b44f0fc7c867bc SHA512 b436576d6c72d0ec285b926f5741b6bdba14fa959248be1c4bdcc8b87dfc512653e48fb2d356ab85d0e90a374c48de5311f43f4f3ce6cb64876e1316c6169423
DIST SQLAlchemy-1.4.3.tar.gz 7479656 BLAKE2B 543ba3f4655e516db82655b1b1814e06fb59e618e3a6d746749763139d9a6ce2cfa2d403cc0d48a80f7455bb4547077036973d5022f8298cfe0c95c5417df648 SHA512 cdb133b2feb480aa9d10f7e38d5c8342ceca327013a9cfea814887cc28eb544f79afc50a08d735195ad0130961429145ef0e641b17584ccb7aec6461cb9e7b15
+DIST SQLAlchemy-1.4.4.tar.gz 7486363 BLAKE2B 4472451e7e3d96c1887b3e896801f587009dc0d41d442790430407963e0e140995a18d2ff8698766245c3b884c6a4679f25d58dba5688ce18dea2ba5011e70ba SHA512 5543effc860e81e1a9c5ceca7ccd521411460ed9a950a33cd0f5c9df6a25eff2d2ef1b49b6e1b2630c2f46aeb09356a51d6152aa7de76d17d9c8aa77c89d479c
diff --git a/dev-python/sqlalchemy/sqlalchemy-1.4.4.ebuild b/dev-python/sqlalchemy/sqlalchemy-1.4.4.ebuild
new file mode 100644
index 000000000000..358669239962
--- /dev/null
+++ b/dev-python/sqlalchemy/sqlalchemy-1.4.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+PYTHON_REQ_USE="sqlite?"
+
+inherit distutils-r1 multiprocessing optfeature
+
+MY_PN="SQLAlchemy"
+MY_P="${MY_PN}-${PV/_beta/b}"
+
+DESCRIPTION="Python SQL toolkit and Object Relational Mapper"
+HOMEPAGE="https://www.sqlalchemy.org/ https://pypi.org/project/SQLAlchemy/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="examples +sqlite test"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ ' python3_7 pypy3)
+"
+# Use pytest-xdist to speed up tests
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove optional/partial dep on greenlet, greenlet is not very portable
+ sed -i -e '/greenlet/d' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Disable tests hardcoding function call counts specific to Python versions.
+ epytest --ignore test/aaa_profiling \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "MySQL support" dev-python/mysqlclient dev-python/pymysql \
+ dev-python/mysql-connector-python
+ optfeature "mssql support" dev-python/pymssql
+ optfeature "postgresql support" dev-python/psycopg:2
+}