summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-09-16 19:25:40 +0200
committerUlrich Müller <ulm@gentoo.org>2023-11-19 11:14:09 +0100
commit7b7ff01e6eeb29b2526d14d2187c2d489d17541d (patch)
treee15660e002e1221ae1cb394f723b6b825e26bfef
parentnet-misc/taptap: remove old (diff)
downloadgentoo-7b7ff01e6eeb29b2526d14d2187c2d489d17541d.tar.gz
gentoo-7b7ff01e6eeb29b2526d14d2187c2d489d17541d.tar.bz2
gentoo-7b7ff01e6eeb29b2526d14d2187c2d489d17541d.zip
app-text/itex2mml: EAPI8 bump, version bump (v1.6.1)
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://bugs.gentoo.org/719070 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-text/itex2mml/Manifest1
-rw-r--r--app-text/itex2mml/itex2mml-1.6.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/itex2mml/Manifest b/app-text/itex2mml/Manifest
index b3afe26bca2a..aeeb0c6baf85 100644
--- a/app-text/itex2mml/Manifest
+++ b/app-text/itex2mml/Manifest
@@ -1 +1,2 @@
DIST itexToMML-1.5.6.tar.gz 155394 BLAKE2B be83c2de3a7ffd0a60fa45c38bb7fb224afbbfe3e715d09813137886ab0274fad4670a6156066e2f4f15ea1e3ff63f9f5cb4a30fc64256801af45455ea3d498b SHA512 2f4ebcaccbef71ba1728909bdc60abf06606cfe267481835315fb1ecaa365641e45dfad370cffb758153379e721bde48e71ff660b0cba511f8d8db8a4aec0171
+DIST itexToMML-1.6.1.tar.gz 513185 BLAKE2B d3bf94a0eb95b7c448e0691e4ae5bd6ba37de97f86331ebaad5dea034d0bb259514b3acee0c926b711500ce0f7069ec95838a172385d9459167a7a3b29200d77 SHA512 6d35c5d2b5c5bbf8e1a938c5a7005dd32af85896df812e305931b4d8aafd57c2c4b31311495477109d53a6447ddfa9ffa2af3c92fb8176157d651851a2383409
diff --git a/app-text/itex2mml/itex2mml-1.6.1.ebuild b/app-text/itex2mml/itex2mml-1.6.1.ebuild
new file mode 100644
index 000000000000..4b5b27122fed
--- /dev/null
+++ b/app-text/itex2mml/itex2mml-1.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="LaTeX to XHTML/MathML converter"
+HOMEPAGE="https://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+SRC_URI="https://golem.ph.utexas.edu/~distler/blog/files/itexToMML-${PV}.tar.gz"
+S="${WORKDIR}/itexToMML/itex-src"
+
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+src_configure() {
+ # fix bug #719070
+ sed -i -e "s/\$(CXX) \$(CFLAGS)/ \$(CXX) ${CFLAGS} ${LDFLAGS}/" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin itex2MML
+ dodoc ../README
+}