summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-04-30 16:05:10 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-04-30 16:10:25 +0200
commit7b8e7be874cc59ed0b17f31dd04f83660277d6eb (patch)
treedcf40b69d38464796122cb78882efdf536efe5ff
parentapp-metrics/collectd: add check_uptime plugin (diff)
downloadgentoo-7b8e7be8.tar.gz
gentoo-7b8e7be8.tar.bz2
gentoo-7b8e7be8.zip
app-metrics/collectd: add connectivity plugin
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--app-metrics/collectd/collectd-5.11.0.ebuild13
-rw-r--r--profiles/desc/collectd_plugins.desc1
2 files changed, 8 insertions, 6 deletions
diff --git a/app-metrics/collectd/collectd-5.11.0.ebuild b/app-metrics/collectd/collectd-5.11.0.ebuild
index 6f5057626b3b..11461aaddc63 100644
--- a/app-metrics/collectd/collectd-5.11.0.ebuild
+++ b/app-metrics/collectd/collectd-5.11.0.ebuild
@@ -49,12 +49,12 @@ COLLECTD_IMPOSSIBLE_PLUGINS="apple_sensors amqp1 aquaero barometer
# Plugins that have been (compile) tested and can be enabled via COLLECTD_PLUGINS
COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
- buddyinfo capabilities ceph cgroups check_uptime chrony conntrack
- contextswitch cpu cpufreq cpusleep csv curl curl_json curl_xml
- dbi df disk dns drbd email entropy ethstat exec fhcount filecount
- fscache gmond gps hddtemp hugepages interface ipc ipmi iptables
- ipvs irq java lua load logfile logparser log_logstash madwifi
- match_empty_counter match_hashed match_regex match_timediff
+ buddyinfo capabilities ceph cgroups check_uptime chrony connectivity
+ conntrack contextswitch cpu cpufreq cpusleep csv curl curl_json
+ curl_xml dbi df disk dns drbd email entropy ethstat exec fhcount
+ filecount fscache gmond gps hddtemp hugepages interface ipc ipmi
+ iptables ipvs irq java lua load logfile logparser log_logstash
+ madwifi match_empty_counter match_hashed match_regex match_timediff
match_value mbmon mcelog md memcachec memcached memory modbus mqtt
multimeter mysql netlink network network nfs nginx notify_desktop
notify_email notify_nagios ntpd numa nut olsrd onewire openldap
@@ -92,6 +92,7 @@ COMMON_DEPEND="
collectd_plugins_bind? ( net-misc/curl:0= dev-libs/libxml2:2= )
collectd_plugins_ceph? ( dev-libs/yajl:= )
collectd_plugins_capabilities? ( sys-libs/libcap dev-libs/jansson net-libs/libmicrohttpd:= )
+ collectd_plugins_connectivity? ( dev-libs/yajl:= net-libs/libmnl )
collectd_plugins_curl? ( net-misc/curl:0= )
collectd_plugins_curl_json? ( net-misc/curl:0= dev-libs/yajl:= )
collectd_plugins_curl_xml? ( net-misc/curl:0= dev-libs/libxml2:2= )
diff --git a/profiles/desc/collectd_plugins.desc b/profiles/desc/collectd_plugins.desc
index 6bf21031d34d..1a323e273a58 100644
--- a/profiles/desc/collectd_plugins.desc
+++ b/profiles/desc/collectd_plugins.desc
@@ -17,6 +17,7 @@ ceph - Build the Ceph input plugin (collects statistics from the Ceph distribute
cgroups - Build the cgroups input plugin (collects CPU accounting information for processes in a cgroup)
check_uptime - Build a plugin to notify about uptime reset
chrony - Build the chrony input plugin (collects statistics from a chrony NTP server)
+connectivity - Build the connectivity input plugin (monitors interface up/down status via netlink library)
conntrack - Build the conntrack input plugin (tracks the number of entries in Linux's connection tracking table)
contextswitch - Build the contextswitch input plugin (collects the number of context switches done by the operating system)
cpu - Build the cpu input plugin (collects the amount of time spent by the CPU in various states)