summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-04 19:29:25 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-04 19:33:42 +0200
commit7ba2e7936c6eb44b222e199950e213444c007b79 (patch)
treec0c3f581da594aa77011fa57d4f1f41ccf81e91f
parentdev-python/keyrings_alt: Version bump to 2.2 (diff)
downloadgentoo-7ba2e793.tar.gz
gentoo-7ba2e793.tar.bz2
gentoo-7ba2e793.zip
xfce-extra/xfce4-sensors-plugin: Bump to 1.2.98
-rw-r--r--xfce-extra/xfce4-sensors-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.98.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/Manifest b/xfce-extra/xfce4-sensors-plugin/Manifest
index 208974b360eb..be058bb4b25c 100644
--- a/xfce-extra/xfce4-sensors-plugin/Manifest
+++ b/xfce-extra/xfce4-sensors-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-sensors-plugin-1.2.6.tar.bz2 454524 SHA256 235ef842bd45e701bceebb21a384ab09f21afceea8ed95f91bb4c6cf3abe1bc0 SHA512 5c520f1c253df1bb9e29855c5ccfc1536034945ca68b43cd8b6d97083e528b2430230d9c51d43953a71c3f0171ae718bf1557714729b1343ebd51f91f3f36d60 WHIRLPOOL 60b1069b621026f37637ca93a5c8a956eb77ee234df472fef9c2f3bec56efc5f09d923e23fd7ab8ed76526a14ad414b3d82f2c2c2d7ab68118b4bafbe4add9f0
DIST xfce4-sensors-plugin-1.2.97.tar.bz2 476012 SHA256 7524ec4534de9ef7f676de2895a41bf70b73b94da5a27fd4a022b16eda56d0f4 SHA512 4083dda80ae74fd4b2e56da0a656da5a1926e40fed7715151e428abd85ed1a6f8e57208086bf769bf2f9668e63c2923ebab31ee68deb5279b68d627e5c2e47cb WHIRLPOOL 2ed692320144ac14571fdb61ed69958c5d3d5863d3314373591a1cd90166c0260c241e18db29e23d543864ada7e84da2d2cdbf0f552b269f9c9c8e12c666046c
+DIST xfce4-sensors-plugin-1.2.98.tar.bz2 477241 SHA256 201232296ccc69f2f2739c6c73a2d2404e108997441099377c98503a0b840ed1 SHA512 6437acc17d2719e3deef011c206c8c5593f4b14a8263e82bb3b0e8b1cb7e17e842adf2cb3a479e1a8e2729db744df2778ee04bc9af5e4c918f417e1c8ac4d17e WHIRLPOOL 0e3b732535646419f0f9be016af8e6cdbbf193a1db3e0f5e273c6dbde977b1ecd075a3c359eac254ae637764a2e05c28431b931151593f19d2b6da325e45e642
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.98.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.98.ebuild
new file mode 100644
index 000000000000..7d766ffc1882
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.2.98.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A panel plug-in for acpi, lm_sensors and hddtemp sensors"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="+acpi hddtemp libnotify lm_sensors video_cards_nvidia"
+
+REQUIRED_USE="|| ( hddtemp lm_sensors acpi )"
+
+RDEPEND=">=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+ hddtemp? ( app-admin/hddtemp net-analyzer/gnu-netcat )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ lm_sensors? ( >=sys-apps/lm_sensors-3.1.0:= )
+ video_cards_nvidia? (
+ || (
+ x11-drivers/nvidia-drivers[tools,static-libs]
+ media-video/nvidia-settings
+ )
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS NOTES README TODO )
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable lm_sensors libsensors)
+ $(use_enable hddtemp)
+ $(use_enable hddtemp netcat)
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable video_cards_nvidia xnvctrl)
+ $(use_enable libnotify notification)
+ --disable-pathchecks
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install manualdir="${EPREFIX}/usr/share/man/man1"
+}