summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-08 15:41:05 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-08 15:41:27 +0100
commit7badf35b70253965e966a33ad64b24617a0a7651 (patch)
treedffaebbede1d1b30d90be04379cb10d325316672
parentdev-python/klein: Enable py3.12 (diff)
downloadgentoo-7badf35b70253965e966a33ad64b24617a0a7651.tar.gz
gentoo-7badf35b70253965e966a33ad64b24617a0a7651.tar.bz2
gentoo-7badf35b70253965e966a33ad64b24617a0a7651.zip
dev-python/dominate: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/dominate/dominate-2.8.0.ebuild7
-rw-r--r--dev-python/dominate/files/dominate-2.8.0-py312.patch20
2 files changed, 26 insertions, 1 deletions
diff --git a/dev-python/dominate/dominate-2.8.0.ebuild b/dev-python/dominate/dominate-2.8.0.ebuild
index b6dce9410d70..744551817283 100644
--- a/dev-python/dominate/dominate-2.8.0.ebuild
+++ b/dev-python/dominate/dominate-2.8.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1 pypi
@@ -19,3 +19,8 @@ SLOT="0"
KEYWORDS="amd64 x86"
distutils_enable_tests pytest
+
+PATCHES=(
+ # quick hack, already fixed in git
+ "${FILESDIR}/${P}-py312.patch"
+)
diff --git a/dev-python/dominate/files/dominate-2.8.0-py312.patch b/dev-python/dominate/files/dominate-2.8.0-py312.patch
new file mode 100644
index 000000000000..ffd010caf735
--- /dev/null
+++ b/dev-python/dominate/files/dominate-2.8.0-py312.patch
@@ -0,0 +1,20 @@
+diff --git a/setup.py b/setup.py
+index f83890f..5454cc3 100644
+--- a/setup.py
++++ b/setup.py
+@@ -19,14 +19,11 @@ Public License along with dominate. If not, see
+
+ from setuptools import setup
+
+-import imp
+-_version = imp.load_source("dominate._version", "dominate/_version.py")
+-
+ long_description = open('README.md').read()
+
+ setup(
+ name = 'dominate',
+- version = _version.__version__,
++ version = '2.8.0',
+ author = 'Tom Flanagan and Jake Wharton',
+ author_email = 'tom@zkpq.ca',
+ license = 'LGPLv3',