summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-12-03 10:51:19 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-12-03 10:52:32 -0600
commit7bba4eb59a368b70758cf495a588d80d8a53903b (patch)
tree6d13375482239779d00053dd0e1fbaf2b0cea407
parentnet-misc/youtube-dl: Old (diff)
downloadgentoo-7bba4eb59a368b70758cf495a588d80d8a53903b.tar.gz
gentoo-7bba4eb59a368b70758cf495a588d80d8a53903b.tar.bz2
gentoo-7bba4eb59a368b70758cf495a588d80d8a53903b.zip
net-firewall/nftables: fix modern_kernel flag
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--net-firewall/nftables/nftables-0.9.3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-firewall/nftables/nftables-0.9.3.ebuild b/net-firewall/nftables/nftables-0.9.3.ebuild
index ad90d7a06730..26df15a2aeaa 100644
--- a/net-firewall/nftables/nftables-0.9.3.ebuild
+++ b/net-firewall/nftables/nftables-0.9.3.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://netfilter.org/projects/nftables/files/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~sparc ~x86"
-IUSE="debug +doc +gmp json +modern_kernel python +readline static-libs xtables"
+IUSE="debug +doc +gmp json +modern-kernel python +readline static-libs xtables"
RDEPEND="
>=net-libs/libmnl-1.0.3:0=
@@ -52,8 +52,8 @@ python_make() {
pkg_setup() {
if kernel_is ge 3 13; then
- if use modern_kernel && kernel_is lt 3 18; then
- eerror "The modern_kernel USE flag requires kernel version 3.18 or newer to work properly."
+ if use modern-kernel && kernel_is lt 3 18; then
+ eerror "The modern-kernel USE flag requires kernel version 3.18 or newer to work properly."
fi
CONFIG_CHECK="~NF_TABLES"
linux-info_pkg_setup
@@ -101,7 +101,7 @@ src_compile() {
src_install() {
default
- local mksuffix="$(usex modern_kernel '-mk' '')"
+ local mksuffix="$(usex modern-kernel '-mk' '')"
exeinto /usr/libexec/${PN}
newexe "${FILESDIR}"/libexec/${PN}${mksuffix}.sh ${PN}.sh