summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-29 23:08:08 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-29 23:08:30 +1200
commit7bc55c9f4017f3895439df7f4a1300cb49adc4da (patch)
tree075ca4b28db1b0f82e5ec2f0a91e080aea62566d
parentdev-python/pytest-rerunfailures: Add missing mock py2-test-dep (diff)
downloadgentoo-7bc55c9f.tar.gz
gentoo-7bc55c9f.tar.bz2
gentoo-7bc55c9f.zip
dev-perl/Audio-Musepack: -r bump for EAPI7
- EAPI7 - Remove empty variable assignments - Add license note - Use patch files instead of sed - Trim cruft tests Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Audio-Musepack/Audio-Musepack-1.0.1-r1.ebuild25
-rw-r--r--dev-perl/Audio-Musepack/files/Audio-Musepack-1.0.1-no-dot-inc.patch21
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Audio-Musepack/Audio-Musepack-1.0.1-r1.ebuild b/dev-perl/Audio-Musepack/Audio-Musepack-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..d48943c001d5
--- /dev/null
+++ b/dev-perl/Audio-Musepack/Audio-Musepack-1.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=DANIEL
+inherit perl-module
+
+DESCRIPTION="An OO interface to Musepack file information and APE tag fields"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# License note: says perl 5.8.2 or later
+
+RDEPEND="
+ >=dev-perl/Audio-Scan-0.850.0
+"
+BDEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.420.0
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.1-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod-coverage.t"
+)
diff --git a/dev-perl/Audio-Musepack/files/Audio-Musepack-1.0.1-no-dot-inc.patch b/dev-perl/Audio-Musepack/files/Audio-Musepack-1.0.1-no-dot-inc.patch
new file mode 100644
index 000000000000..f7491838b140
--- /dev/null
+++ b/dev-perl/Audio-Musepack/files/Audio-Musepack-1.0.1-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 25eb918a143c78de972c4218f9fe5b0aefbe7e3e Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 29 Apr 2020 23:01:40 +1200
+Subject: Include '.' in @INC on 5.28+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index de8142b..5c84f30 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib '.';
+ use inc::Module::Install;
+
+ name('Audio-Musepack');
+--
+2.26.2
+