summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Qian <i@bitbili.net>2023-11-15 05:14:05 +0800
committerYixun Lan <dlan@gentoo.org>2023-11-17 01:49:06 +0000
commit7bf41879db42ed6108bdcd9b08b4c5a10b90d22a (patch)
tree82ea2eb938b7c789abc5f02c9bdc52c78c01c6bb
parentwww-apps/gitea: add 1.21.0 (diff)
downloadgentoo-7bf41879db42ed6108bdcd9b08b4c5a10b90d22a.tar.gz
gentoo-7bf41879db42ed6108bdcd9b08b4c5a10b90d22a.tar.bz2
gentoo-7bf41879db42ed6108bdcd9b08b4c5a10b90d22a.zip
www-apps/gitea: update the systemd service file for new postgresql versions
Closes: https://github.com/gentoo/gentoo/pull/33825 Signed-off-by: Ryan Qian <i@bitbili.net> Signed-off-by: Yixun Lan <dlan@gentoo.org>
-rw-r--r--www-apps/gitea/files/gitea.service-r434
-rw-r--r--www-apps/gitea/gitea-1.21.0.ebuild2
2 files changed, 35 insertions, 1 deletions
diff --git a/www-apps/gitea/files/gitea.service-r4 b/www-apps/gitea/files/gitea.service-r4
new file mode 100644
index 000000000000..3fa73aaf1db8
--- /dev/null
+++ b/www-apps/gitea/files/gitea.service-r4
@@ -0,0 +1,34 @@
+[Unit]
+Description=Gitea service
+Documentation=https://docs.gitea.io/
+
+AssertPathIsDirectory=/var/lib/gitea
+AssertPathIsReadWrite=/var/lib/gitea
+
+After=network.target
+Requires=network.target
+After=mysqld.service
+After=postgresql-10.service
+After=postgresql-11.service
+After=postgresql-12.service
+After=postgresql-13.service
+After=postgresql-14.service
+After=postgresql-15.service
+After=postgresql-16.service
+After=memcached.service
+After=redis.service
+
+[Service]
+User=git
+Group=git
+
+Environment="GITEA_WORK_DIR=/var/lib/gitea" "GITEA_CUSTOM=/var/lib/gitea/custom"
+WorkingDirectory=/var/lib/gitea
+ExecStart=/usr/bin/gitea --config /etc/gitea/app.ini web
+
+Restart=always
+PrivateTmp=true
+Nice=5
+
+[Install]
+WantedBy=multi-user.target
diff --git a/www-apps/gitea/gitea-1.21.0.ebuild b/www-apps/gitea/gitea-1.21.0.ebuild
index c3878c4ba16b..fce72a8ba35f 100644
--- a/www-apps/gitea/gitea-1.21.0.ebuild
+++ b/www-apps/gitea/gitea-1.21.0.ebuild
@@ -101,7 +101,7 @@ src_install() {
newtmpfiles - gitea.conf <<-EOF
d /run/gitea 0755 git git
EOF
- systemd_newunit "${FILESDIR}"/gitea.service-r3 gitea.service
+ systemd_newunit "${FILESDIR}"/gitea.service-r4 gitea.service
insinto /etc/gitea
newins custom/conf/app.example.ini app.ini