summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-07 23:22:09 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-07 23:22:09 +0200
commit7c03dbbfdb013806711b5673af14fb6ef28d1d30 (patch)
treee67dd3487a3eeb513dcc522cfcd189d7571e06b9
parentdev-python/spotipy: bump to 2.23.0 (diff)
downloadgentoo-7c03dbbfdb013806711b5673af14fb6ef28d1d30.tar.gz
gentoo-7c03dbbfdb013806711b5673af14fb6ef28d1d30.tar.bz2
gentoo-7c03dbbfdb013806711b5673af14fb6ef28d1d30.zip
dev-lang/typescript: bump to 5.0.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-5.0.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index f30db9db389b..69fc9b3a1fed 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1,3 +1,4 @@
DIST typescript-4.9.5.tgz 11620433 BLAKE2B c253379a4aadd3fe16c93f27c5b450e5965c4c4de6841737c3489c74baa2cf8f8f5d9ca0414b5519e26eaac1db058e3826a3aa504bb450a89d36dce7e21b5f99 SHA512 d455e4f44d879be433650ef3f8c7098872f8356d45d84cccbbd36af62df301a1aa89b69fa98c02554e96c9602ec90451cce971a2ef31652c972c437ca0a8f6e2
DIST typescript-5.0.2.tgz 7050986 BLAKE2B 6f9a187eb6f87971540469f6b212ce25e04b6ee22b8aab0d86857e99feed1ed10603b6367a9d4d0ac448669225b228d233995bae6391aeb1df75374c70b3f757 SHA512 c1539130118efc502cffef9b94635e01575b34ab48875adb04bd84c90d7e27d942949f772a288a7bc3e614855d5e11dccafe3848bf6882599f792b27768d2347
DIST typescript-5.0.3.tgz 7051270 BLAKE2B 6879f0b4ed07e23dbd7e050c2740100af922ddd09f2989171d46408516026d3eaf548c90286d0bfc0606edeba9e40a39381042130011b029250c5b87efa60f7d SHA512 c6ff263840e78a06ffb4df4f48c4f0484a809d4be4a1731096270e6f421454305240280149a00044e519632d88714cb9a94e976a32b98e38ceed3316a814ca64
+DIST typescript-5.0.4.tgz 7051452 BLAKE2B ed08425d8324a910f2d328fb02f27e08f75334fb190d1c4625452d076d615726d0e852da06f0f25146a4b02c6c99cd569bbcf7c50f5d6ff32c88a40101a59656 SHA512 716f53e56f71637edc73e8df127694bd7f757e8c6d1e4cdadcdc37c24a05e2c4a52a7d0c38d7647449dd8a0fea3c15973649a9961dcdcdac90cc2887338fe1ab
diff --git a/dev-lang/typescript/typescript-5.0.4.ebuild b/dev-lang/typescript/typescript-5.0.4.ebuild
new file mode 100644
index 000000000000..598301d43b33
--- /dev/null
+++ b/dev-lang/typescript/typescript-5.0.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org/
+ https://github.com/microsoft/TypeScript/"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+S="${WORKDIR}"/package
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+src_compile() {
+ # Skip, nothing to compile here.
+ :
+}
+
+src_install() {
+ local myopts=(
+ --audit false
+ --color false
+ --foreground-scripts
+ --global
+ --offline
+ --omit dev
+ --prefix "${ED}"/usr
+ --progress false
+ --verbose
+ )
+ npm ${myopts[@]} install "${DISTDIR}"/${P}.tgz || die "npm install failed"
+
+ dodoc *.md *.txt
+}