summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-16 05:52:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-16 05:52:55 +0200
commit7c0ab94a9dbfa2ddd330cffb415ffe739f94cccf (patch)
tree563856897c09a51f354d336cc4a4b27ead1d607f
parentdev-python/kombu: Bump to 5.3.1 (diff)
downloadgentoo-7c0ab94a.tar.gz
gentoo-7c0ab94a.tar.bz2
gentoo-7c0ab94a.zip
dev-python/openapi-core: Bump to 0.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.17.2.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index 504d2642adc0..58ca8f91edaa 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,2 +1,3 @@
DIST openapi-core-0.16.6.gh.tar.gz 104008 BLAKE2B bb1bdac98dfc5aef0961624488074363568f53a6c44cb0730be0d103d891d24bed86659f640e0d07da4072edc233c904c0ddcfd9e8b3960ace1af078c0d745e5 SHA512 556636a4698dcd7db6c656333849077abacdac1a440fe58210ad8f02c1f0220e46dea29962346dfb3f89d164ebc986ec750c184840be9a34a5e1dd98fbf8ef98
DIST openapi_core-0.17.1.tar.gz 85686 BLAKE2B f18b42fc496eaf4d6b82c15f66dd9c2eb9240402590b5a8e1f0e7b1e804c90aeef2db96d19683e9fea5846e776e95981ac52a38c47e2b56e6b5fd63d072b61f7 SHA512 0e2c673dbbfcce87ae7fbca6ec6c283d94c36376b1e17191d0bfa6c7001c62913381169b4614b5cd6131eaa67b729365036be3f1eb7641f634c0f3228de54897
+DIST openapi_core-0.17.2.tar.gz 88262 BLAKE2B 4d9a1be1eff4118bc1c687e57af0ff3738f984ceb6e564c643d26cb795bbcd3e703dd22c3b45d574f498d290f8da225819c9df618da5a1b8e40758304f2ebd07 SHA512 73cd2b62149549bd56781adb44922bca4a0519fbae8b6539d0225799ba1cfa1ab584428fd572ee42af4731b5437f08b8c4ad8f8895444aef315e4c6909fd4e5a
diff --git a/dev-python/openapi-core/openapi-core-0.17.2.ebuild b/dev-python/openapi-core/openapi-core-0.17.2.ebuild
new file mode 100644
index 000000000000..a9480b6e0bf6
--- /dev/null
+++ b/dev-python/openapi-core/openapi-core-0.17.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
+HOMEPAGE="
+ https://github.com/python-openapi/openapi-core/
+ https://pypi.org/project/openapi-core/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.6.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-5[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.17.3[${PYTHON_USEDEP}]
+ <dev-python/jsonschema-spec-0.2[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.1.6[${PYTHON_USEDEP}]
+ <dev-python/lazy-object-proxy-2[${PYTHON_USEDEP}]
+ >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.5[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.4.2[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ >=dev-python/aiohttp-3.8.4[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.24.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-aiohttp-1.0.4[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.26.1[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # falcon is not packaged
+ tests/integration/contrib/falcon
+
+ # TODO: these tests fail to collect
+ tests/integration/validation/test_security_override.py
+ tests/integration/validation/test_read_only_write_only.py
+
+ # unhappy about modern django
+ tests/integration/contrib/django/test_django_project.py
+ tests/unit/contrib/django/test_django.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}