summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Kappus <joe@wt.gd>2022-12-11 02:40:34 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-13 13:04:00 -0500
commit7c1742125eb8b13710cef3a41e11d0501218f5b1 (patch)
treec51cba5eac6749a4343f4a446b7b515289d4eac3
parentwww-client/chromium: Stabilize 108.0.5359.98 amd64, #884139 (diff)
downloadgentoo-7c1742125eb8b13710cef3a41e11d0501218f5b1.tar.gz
gentoo-7c1742125eb8b13710cef3a41e11d0501218f5b1.tar.bz2
gentoo-7c1742125eb8b13710cef3a41e11d0501218f5b1.zip
dev-libs/wayland-protocols: Version bump to 1.31
Closes: https://bugs.gentoo.org/885675 Closes: https://github.com/gentoo/gentoo/pull/28635 Signed-off-by: Joe Kappus <joe@wt.gd> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.31.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 9b8d23650551..cfc2c60021f7 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,2 +1,3 @@
DIST wayland-protocols-1.27.tar.xz 82604 BLAKE2B ae1c19dffcf255c88e6d646f321ec194639500994f9e5a2759bd7081dc16872777c993d35d81000796e3e5044dc62f169c9b2fe89de081fd395eaaf09e6206e2 SHA512 c0a49bc46c663c9f602998dfe2e184c09756790fbcc7acbc2bf9d9cf8f7d6dcdd00259b768222a30e5d134e6f97f7f4faf252947b544e8b32f53278b70da0390
DIST wayland-protocols-1.30.tar.xz 84776 BLAKE2B 059a40c839c5775851fb31f3f4637e11dce091b1758a5eb0c375ae40c3b745321cdc549d26456edc1bf66cd7d013d370c3df8c0de64f867b899571a73e2a4233 SHA512 e1e5648387e821c190058b390d7120c06c2767b644caf2644f05a280e0fe300b677545fbb9537839d8bc569a0cc7fb51190963421281e2557d1680767899b743
+DIST wayland-protocols-1.31.tar.xz 85524 BLAKE2B c3c21eb44f31fda1901b7aa87b15420f246893184f114d1776ef54224d4d05255b7691349ba546ba782df8fcbd64e39446caa11e2f96125cad9acb1cefad5f3d SHA512 402ce1915300e29afe554d77965ee0a28a5f22fdb5b901c4c640e59b9f3a9c11094e1edae87eea1e76eea557f6faf0c34a0c28ee7f6babb4dc3719329c4e25bf
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.31.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.31.ebuild
new file mode 100644
index 000000000000..4eff41270cb0
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.31.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+RDEPEND=""
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}