summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-29 00:50:05 +0000
committerSam James <sam@gentoo.org>2024-02-29 00:50:07 +0000
commit7c5bf9a42324f8c9958f7f251d0396868b3e9481 (patch)
tree418c482cb05a165b84dbfe0bbaf533ca4cc7ecc0
parentdev-ruby/coolio: filter LTO, no-SA (diff)
downloadgentoo-7c5bf9a42324f8c9958f7f251d0396868b3e9481.tar.gz
gentoo-7c5bf9a42324f8c9958f7f251d0396868b3e9481.tar.bz2
gentoo-7c5bf9a42324f8c9958f7f251d0396868b3e9481.zip
dev-ruby/nio4r: filter LTO, no-SA
Broken quite badly via bundled liebv, no upstream bug tracker for libev AFAICT. And broken in many bundled copies all over the place (which are modified...) Closes: https://bugs.gentoo.org/857741 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/nio4r/nio4r-2.5.9.ebuild8
-rw-r--r--dev-ruby/nio4r/nio4r-2.6.1.ebuild8
-rw-r--r--dev-ruby/nio4r/nio4r-2.7.0.ebuild8
3 files changed, 18 insertions, 6 deletions
diff --git a/dev-ruby/nio4r/nio4r-2.5.9.ebuild b/dev-ruby/nio4r/nio4r-2.5.9.ebuild
index c9d939af7596..a6b35ed1088d 100644
--- a/dev-ruby/nio4r/nio4r-2.5.9.ebuild
+++ b/dev-ruby/nio4r/nio4r-2.5.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
RUBY_FAKEGEM_EXTENSIONS=(ext/nio4r/extconf.rb)
-inherit ruby-fakegem
+inherit flag-o-matic ruby-fakegem
DESCRIPTION="A high performance selector API for monitoring IO objects"
HOMEPAGE="https://github.com/socketry/nio4r"
@@ -26,6 +26,10 @@ IUSE=""
# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
sed -e '/extension/ s:^:#:' -i Rakefile || die
}
diff --git a/dev-ruby/nio4r/nio4r-2.6.1.ebuild b/dev-ruby/nio4r/nio4r-2.6.1.ebuild
index 381b1a8e8790..6fe4a3605cb9 100644
--- a/dev-ruby/nio4r/nio4r-2.6.1.ebuild
+++ b/dev-ruby/nio4r/nio4r-2.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ RUBY_FAKEGEM_EXTRADOC="changes.md readme.md"
RUBY_FAKEGEM_EXTENSIONS=(ext/nio4r/extconf.rb)
-inherit ruby-fakegem
+inherit flag-o-matic ruby-fakegem
DESCRIPTION="A high performance selector API for monitoring IO objects"
HOMEPAGE="https://github.com/socketry/nio4r"
@@ -26,6 +26,10 @@ IUSE=""
# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
sed -e '/extension/ s:^:#:' -i Rakefile || die
}
diff --git a/dev-ruby/nio4r/nio4r-2.7.0.ebuild b/dev-ruby/nio4r/nio4r-2.7.0.ebuild
index 6bde0afc66c8..8196c914fa21 100644
--- a/dev-ruby/nio4r/nio4r-2.7.0.ebuild
+++ b/dev-ruby/nio4r/nio4r-2.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -12,7 +12,7 @@ RUBY_FAKEGEM_EXTRADOC="changes.md readme.md"
RUBY_FAKEGEM_EXTENSIONS=(ext/nio4r/extconf.rb)
-inherit ruby-fakegem
+inherit flag-o-matic ruby-fakegem
DESCRIPTION="A high performance selector API for monitoring IO objects"
HOMEPAGE="https://github.com/socketry/nio4r"
@@ -26,6 +26,10 @@ IUSE=""
# patches the tests fail: https://github.com/celluloid/nio4r/issues/15
all_ruby_prepare() {
+ # See bug #855869 and its large number of dupes in bundled libev copies.
+ filter-lto
+ append-flags -fno-strict-aliasing
+
sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die
sed -e '/extension/ s:^:#:' -i Rakefile || die
}