summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-26 05:34:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-26 05:34:01 +0100
commit7c63d887c8b1b9274eb8f41e01b021f7c274e022 (patch)
tree3641d0fad88e31cd56d7683c5fd42daa21be0b27
parentdev-python/progressbar2: Bump to 4.4.1 (diff)
downloadgentoo-7c63d887c8b1b9274eb8f41e01b021f7c274e022.tar.gz
gentoo-7c63d887c8b1b9274eb8f41e01b021f7c274e022.tar.bz2
gentoo-7c63d887c8b1b9274eb8f41e01b021f7c274e022.zip
dev-python/crispy-bootstrap5: Bump to 2024.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/crispy-bootstrap5/Manifest1
-rw-r--r--dev-python/crispy-bootstrap5/crispy-bootstrap5-2024.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/crispy-bootstrap5/Manifest b/dev-python/crispy-bootstrap5/Manifest
index c1c0406bb433..326f43b48543 100644
--- a/dev-python/crispy-bootstrap5/Manifest
+++ b/dev-python/crispy-bootstrap5/Manifest
@@ -1 +1,2 @@
DIST crispy-bootstrap5-2023.10.gh.tar.gz 31222 BLAKE2B cab972ed222ba0245d0a0d6e75487aac03c054f8669859fc4eb8293c2abb3775ef76f6866402917d1d1bfa0444548983639a24bd5fd4d1c2a3bbd74d1c086057 SHA512 379e4ea536809ceeb347d8894953acd97362c7340cb496727e4f56c2967aba93b1b041166ba6b8253d4952e4fa97f80668041733ddbd2ca62b60f4f9046259ef
+DIST crispy-bootstrap5-2024.2.gh.tar.gz 33509 BLAKE2B 4a1eec0cea4ee2b0fcbdd8aec6b4595a7b981b0502113d5154585702cc20d9c80cf28fd06db8085dd561c154e13fa493ee88bc3a9c0e619684ab56fce1376d70 SHA512 08c0e35caff14c53976283a383da5a8115a64b42a5a0797089c2528f3e2c0e03eb0826f48c1991bdbbd183afc486c0a238c73e782a76eac1d003e5760ddd852e
diff --git a/dev-python/crispy-bootstrap5/crispy-bootstrap5-2024.2.ebuild b/dev-python/crispy-bootstrap5/crispy-bootstrap5-2024.2.ebuild
new file mode 100644
index 000000000000..ccc2aa04abb8
--- /dev/null
+++ b/dev-python/crispy-bootstrap5/crispy-bootstrap5-2024.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap5 template pack for django-crispy-forms"
+HOMEPAGE="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/
+ https://pypi.org/project/crispy-bootstrap5/
+"
+SRC_URI="
+ https://github.com/django-crispy-forms/crispy-bootstrap5/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/django-4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-crispy-forms-2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest