summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-02-27 13:57:20 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-02-27 13:57:20 -0600
commit7c91ee897602fe5ac64fd91a0f39e6f457acb996 (patch)
tree7b0ae7124cd7e6314de96be0e13c3b963f613e5f
parentmedia-libs/kcolorpicker: Switch to QT_QPA_PLATFORM=offscreen (diff)
downloadgentoo-7c91ee897602fe5ac64fd91a0f39e6f457acb996.tar.gz
gentoo-7c91ee897602fe5ac64fd91a0f39e6f457acb996.tar.bz2
gentoo-7c91ee897602fe5ac64fd91a0f39e6f457acb996.zip
dev-python/urwid: add 2.6.6
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/urwid/Manifest1
-rw-r--r--dev-python/urwid/urwid-2.6.6.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index 0193e6175ea4..c99b1ce9fcb7 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -2,3 +2,4 @@ DIST urwid-2.4.6.tar.gz 801434 BLAKE2B 52b6cd256fbb6f7296619140c0d2cc9dacb910b36
DIST urwid-2.5.3.tar.gz 848047 BLAKE2B 42815e22f2659ee25736767391afbf0189b5bec9d1100ce7631efd037989cfacac7ee921666e2400e1ef7ef114261a948cfac172ac993753ce151b370361d375 SHA512 80c32138347a618fc40e1a26fd174e708a9f8e4e9a8e09edc1d9261a9d73a644e356ce375654a55b5fb8838a820b8ba8b1cc47560c5b44c5c74677399845f578
DIST urwid-2.6.4.tar.gz 848823 BLAKE2B ad0f83f0b610d689b55dbc58464ea170be3ec7ed5f90f9c534b2707bd9fe867fdc06a690adf3357ecd9810f28ffb8126ac9d38068087b166641bcad695768b4e SHA512 659010d1f9f66a70d224a95381b477bd634cc2f90d79f117eba7e7dc7569373fd8c2f8de485e72df21b1434c307232e980a2019b018af662262ea2df4d70558c
DIST urwid-2.6.5.tar.gz 851570 BLAKE2B c99833701b83427005726d9a0d5e1c52f2308617bd7a953370495b0a35fd904c2544a186dd9f74d571045d4dc74af285f9a1da0e3357fdd85ed5ae0162aca3ba SHA512 813b4cfc3f4d418475fdd23b84bf591a6affc30522b18e9f58c067bd71f3bc98962f50866a4b34974d66287a7e5600fdfdf9955fea6cb94c08c1c11a4515e5a8
+DIST urwid-2.6.6.tar.gz 853188 BLAKE2B 95e3a84a8055900d2085a5e49257d1eba91c355cae012896c248d301c89f47a8f9b1b5224f32a9a9b296df11e6754c93164773a58b3d7d17ed5d85cde01b9af3 SHA512 4ef0ac48c83ed0e316918d1964aa5c9b6f402d87e52d87888ff4be8c1d28e5c50cecef3145eb5692f9afccce64d17f1cb70c9328099868dadae2d06c47f0a04f
diff --git a/dev-python/urwid/urwid-2.6.6.ebuild b/dev-python/urwid/urwid-2.6.6.ebuild
new file mode 100644
index 000000000000..0d52239b0d14
--- /dev/null
+++ b/dev-python/urwid/urwid-2.6.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Curses-based user interface library for Python"
+HOMEPAGE="
+ https://urwid.org/
+ https://pypi.org/project/urwid/
+ https://github.com/urwid/urwid/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_test() {
+ rm -rf urwid || die
+ eunittest
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Trio event loop" "dev-python/trio"
+}