summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-03 14:11:10 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-03 14:29:35 +0100
commit7cb013fa5badfe31ab8975d77062f2e46f85c4e4 (patch)
tree79ac81c853cbbff3ae293855ab9c515392ebc8d2
parentapp-shells/bash-completion: Update URLs (diff)
downloadgentoo-7cb013fa.tar.gz
gentoo-7cb013fa.tar.bz2
gentoo-7cb013fa.zip
app-shells/bash-completion: Use epytest to run tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-shells/bash-completion/bash-completion-2.11.ebuild23
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild23
2 files changed, 28 insertions, 18 deletions
diff --git a/app-shells/bash-completion/bash-completion-2.11.ebuild b/app-shells/bash-completion/bash-completion-2.11.ebuild
index 67ec99d5b6ca..5ee98932da25 100644
--- a/app-shells/bash-completion/bash-completion-2.11.ebuild
+++ b/app-shells/bash-completion/bash-completion-2.11.ebuild
@@ -89,20 +89,25 @@ src_prepare() {
eapply "${WORKDIR}/${BASHCOMP_P}/bash-completion-blacklist-support.patch"
fi
- # redhat-specific, we strip these completions
- rm test/t/test_if{down,up}.py || die
- # not available for icedtea
- rm test/t/test_javaws.py || die
-
eapply_user
}
src_test() {
+ local EPYTEST_DESELECT=(
+ # redhat-specific, we strip these completions
+ test/t/test_if{down,up}.py
+ # not available for icedtea
+ test/t/test_javaws.py
+ )
+
# portage's HOME override breaks tests
- local myhome=$(unset HOME; echo ~)
- local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
- addpredict "${myhome}"
- emake check HOME="${myhome}" PYTESTFLAGS="-vv" NETWORK=none
+ local -x HOME=$(unset HOME; echo ~)
+ addpredict "${HOME}"
+ # used in pytest tests
+ local -x NETWORK=none
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ emake -C completions check
+ epytest
}
src_install() {
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index a95ffccbac98..8d39bca2b242 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -94,21 +94,26 @@ src_prepare() {
eapply "${WORKDIR}"/bashcomp2/bash-completion-blacklist-support.patch
fi
- # redhat-specific, we strip these completions
- rm test/t/test_if{down,up}.py || die
- # not available for icedtea
- rm test/t/test_javaws.py || die
-
eapply_user
eautoreconf
}
src_test() {
+ local EPYTEST_DESELECT=(
+ # redhat-specific, we strip these completions
+ test/t/test_if{down,up}.py
+ # not available for icedtea
+ test/t/test_javaws.py
+ )
+
# portage's HOME override breaks tests
- local myhome=$(unset HOME; echo ~)
- local -x SANDBOX_PREDICT=${SANDBOX_PREDICT}
- addpredict "${myhome}"
- emake check HOME="${myhome}" PYTESTFLAGS="-vv" NETWORK=none
+ local -x HOME=$(unset HOME; echo ~)
+ addpredict "${HOME}"
+ # used in pytest tests
+ local -x NETWORK=none
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ emake -C completions check
+ epytest
}
src_install() {