summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2018-09-23 17:22:33 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2018-09-28 02:51:40 +0300
commit7cb13f3214f5cb38fcd015436cf2e8f249a2db12 (patch)
tree7f19b1506f709ddadab85d2f8627ead62bffacf3
parentapp-eselect/eselect-pinentry: eapi bump (diff)
downloadgentoo-7cb13f32.tar.gz
gentoo-7cb13f32.tar.bz2
gentoo-7cb13f32.zip
dev-libs/botan: eapi bump
Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--dev-libs/botan/botan-1.10.17.ebuild8
-rw-r--r--dev-libs/botan/botan-2.7.0.ebuild14
2 files changed, 13 insertions, 9 deletions
diff --git a/dev-libs/botan/botan-1.10.17.ebuild b/dev-libs/botan/botan-1.10.17.ebuild
index 76f17bc19eef..3288e91d07f7 100644
--- a/dev-libs/botan/botan-1.10.17.ebuild
+++ b/dev-libs/botan/botan-1.10.17.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
inherit multilib python-r1 toolchain-funcs
@@ -20,7 +20,9 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}/${MY_P}"
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}
+ bzip2? ( >=app-arch/bzip2-1.0.5 )
zlib? ( >=sys-libs/zlib-1.2.3 )
python? ( ${PYTHON_DEPS} >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}] )
gmp? ( >=dev-libs/gmp-4.2.2:* )
@@ -28,7 +30,7 @@ RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
!libressl? ( <dev-libs/openssl-1.1:0=[bindist=] )
libressl? ( dev-libs/libressl:0= )
)"
-DEPEND="${RDEPEND}
+BDEPEND="dev-lang/python:*
doc? ( dev-python/sphinx )"
PATCHES=(
diff --git a/dev-libs/botan/botan-2.7.0.ebuild b/dev-libs/botan/botan-2.7.0.ebuild
index 9ff13b7881c5..9763cbe67a68 100644
--- a/dev-libs/botan/botan-2.7.0.ebuild
+++ b/dev-libs/botan/botan-2.7.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-inherit multilib python-r1 toolchain-funcs versionator
+inherit multilib python-r1 toolchain-funcs
MY_PN="Botan"
MY_P="${MY_PN}-${PV}"
@@ -13,13 +13,16 @@ HOMEPAGE="https://botan.randombit.net/"
SRC_URI="https://botan.randombit.net/releases/${MY_P}.tgz"
KEYWORDS="amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~ppc-macos"
-SLOT="2/$(get_version_component_range 2)" # soname version
+SLOT="2/$(ver_cut 1-2)" # soname version
LICENSE="BSD"
IUSE="bindist doc boost python bzip2 libressl lzma sqlite ssl static-libs zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
S="${WORKDIR}/${MY_P}"
-RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
+DEPEND="python? ( ${PYTHON_DEPS} )"
+RDEPEND="${DEPEND}
+ bzip2? ( >=app-arch/bzip2-1.0.5 )
zlib? ( >=sys-libs/zlib-1.2.3 )
boost? ( >=dev-libs/boost-1.48 )
lzma? ( app-arch/xz-utils )
@@ -28,8 +31,7 @@ RDEPEND="bzip2? ( >=app-arch/bzip2-1.0.5 )
!libressl? ( dev-libs/openssl:0=[bindist=] )
libressl? ( dev-libs/libressl:0= )
)"
-DEPEND="${RDEPEND}
- dev-lang/python:*
+BDEPEND="dev-lang/python:*
doc? ( dev-python/sphinx )"
src_configure() {