summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-31 09:41:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-31 11:20:56 +0200
commit7cb8bf89dc927f2af9c7ad0f845bc5daf7f04ab5 (patch)
treec1012a2d6be1f1810e1bdf3b296ff1e04ae22d7f
parentdev-python/poetry-core: Bump to 1.1.0 (diff)
downloadgentoo-7cb8bf89.tar.gz
gentoo-7cb8bf89.tar.bz2
gentoo-7cb8bf89.zip
dev-python/botocore: Bump to 1.27.63
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.27.63.ebuild72
-rw-r--r--dev-python/botocore/botocore-9999.ebuild3
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5482b47b4cc9..6611c77c713a 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -15,3 +15,4 @@ DIST botocore-1.27.58.gh.tar.gz 9563088 BLAKE2B 66aecb836cac7bcddbba1fc6b29ce3a2
DIST botocore-1.27.59.gh.tar.gz 9566420 BLAKE2B f8142d7cc16d3cefa9a39a830db97656a920d192d22cccc355dd093c1bc8b49c62af75b3e097ec615c546ff70018e6a9976282fb92c6f29a96f70eb9852b62de SHA512 b330e53fc06f0b067c3bb6ea8981424dc0bd891b7e9ac324201386f6fba12ca74bd9aadf10aaaabd7dc8b18bc943826480648e0a4f82da9ec9a4c5a8ac954cdb
DIST botocore-1.27.60.gh.tar.gz 9574977 BLAKE2B 6dda9bdc9104a4c1deed365a7973008fb07aa3e72d9d47193480c394563ac9dfd61d27e70c906b8c9eeb73e26cae8e250d8249c532a128e14e1819525053e940 SHA512 d271a116cc4c954a49a1d136348cdc42b60f1904f0c7f425e7457008af412eae37dd77740c91ceab3f44f0c97e4ca0e5b117bdf3bc1415e6e44911e1ab830078
DIST botocore-1.27.61.gh.tar.gz 9575336 BLAKE2B bbc2bb49ee84293d9d7d9f0cc3da70a141778bd68ecc45117a9e99bd8ceba7576b52ed0d5381b085c6a7ae32195a6709e76144f27681cd8d07338ed404b1b236 SHA512 1e1ce615a2b02bab2587bb475e783d197cf27496cb1c0c1b06c51453e545ed293b1fab555f23a67246a4a5babb6c5d12fafee2d6f8b997d168e43f62a5e16bfd
+DIST botocore-1.27.63.gh.tar.gz 9581263 BLAKE2B 3b225160fe0095aa77754c874ceff558c56f547e0454a67fd13c8f093abbef975ff5cf878576b4b6235b1783aaae2278d05026b29d41a95e6168928b035cd1fb SHA512 b3698a0d5ea2e63de3fe94441a1781034d24c0ae5ff06a427ac55eb2cdd05bf917b01fcd9e1bbd389a1d4ac6b625d534b37c1d6c8c72b23670b66d892d5fe6da
diff --git a/dev-python/botocore/botocore-1.27.63.ebuild b/dev-python/botocore/botocore-1.27.63.ebuild
new file mode 100644
index 000000000000..d1a6948e70e5
--- /dev/null
+++ b/dev-python/botocore/botocore-1.27.63.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index 6558cbe56a50..d1a6948e70e5 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -63,6 +63,9 @@ python_test() {
# rely on bundled six
tests/functional/test_six_imports.py::test_no_bare_six_imports
tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
)
epytest tests/{functional,unit} -n "$(makeopts_jobs)"