summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-05 08:52:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-05 09:17:55 +0200
commit7cc41a45740c4a047610d856abf2c34f2ae30e85 (patch)
tree129500f0f5b4fed149e321ed4ea9177b2370f29b
parentdev-python/keyring: Bump to 23.9.1 (diff)
downloadgentoo-7cc41a45740c4a047610d856abf2c34f2ae30e85.tar.gz
gentoo-7cc41a45740c4a047610d856abf2c34f2ae30e85.tar.bz2
gentoo-7cc41a45740c4a047610d856abf2c34f2ae30e85.zip
dev-python/antlr4-python3-runtime: Bump to 4.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/antlr4-python3-runtime/Manifest1
-rw-r--r--dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.11.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/antlr4-python3-runtime/Manifest b/dev-python/antlr4-python3-runtime/Manifest
index aa437ca8d82e..61b9f77d9bf6 100644
--- a/dev-python/antlr4-python3-runtime/Manifest
+++ b/dev-python/antlr4-python3-runtime/Manifest
@@ -1 +1,2 @@
DIST antlr-4.10.1.tar.gz 4599964 BLAKE2B 72688b3835350da11c015558a2840428fe69332a7b48992e118cb410005efce6ca5e02e8e5b1cf5edbf2cea506ec30fe516cce5061c52febbdb71f735c1c2cd1 SHA512 d950171d279b57b0fa977c77dd33e56848ca0aaf7f6ba40e5d49d69d5963e4c2e36fde5ee89e98c594064a909396d6fed9cc20129c3a1895d864eb889581e982
+DIST antlr-4.11.1.gh.tar.gz 4383139 BLAKE2B ac6e49ae8d4d44923e40eba98fa2c850cb594929ae1a29223678377aabe6f35d57f95e125393aa6b7145828c876442608883356b594ab43346c891ca932d9fd5 SHA512 a81f2ebcbcb6e63eb651731ceafab55f66401a3da0a6b2688cfe96d3bda299542dab5b05aaf4c8a8520ba32891b23adbf912011a4e45afae492a2a350d333ae9
diff --git a/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.11.1.ebuild b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.11.1.ebuild
new file mode 100644
index 000000000000..13f1fbcbd807
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.11.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 runtime for ANTLR"
+HOMEPAGE="
+ https://www.antlr.org/
+ https://github.com/antlr/antlr4/
+ https://pypi.org/project/antlr4-python3-runtime/
+"
+SRC_URI="
+ https://github.com/antlr/antlr4/archive/${PV}.tar.gz
+ -> antlr-${PV}.gh.tar.gz
+"
+S="${WORKDIR}/antlr4-${PV}/runtime/Python3"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/run.py -v || die "Tests failed with ${EPYTHON}"
+}