summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2020-03-10 11:58:01 -0500
committerWilliam Hubbs <williamh@gentoo.org>2020-03-10 12:00:06 -0500
commit7ccbd128aec124d1d09fef9a72f5c5f3ffea1dd3 (patch)
tree1ae4f0fa183880ca043055dd2720ade76fdcc185
parentdev-python/django-pglocks: context managers for advisory locks for pgsql (diff)
downloadgentoo-7ccbd128.tar.gz
gentoo-7ccbd128.tar.bz2
gentoo-7ccbd128.zip
www-netbox: 2.7.8 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--www-apps/netbox/Manifest1
-rw-r--r--www-apps/netbox/netbox-2.7.8.ebuild123
2 files changed, 124 insertions, 0 deletions
diff --git a/www-apps/netbox/Manifest b/www-apps/netbox/Manifest
index ea740a10b90f..671b5fa49449 100644
--- a/www-apps/netbox/Manifest
+++ b/www-apps/netbox/Manifest
@@ -9,3 +9,4 @@ DIST netbox-2.6.7.tar.gz 2416096 BLAKE2B 9c9744b60c3999fa7c3336539937cc20eebac67
DIST netbox-2.6.8.tar.gz 2416523 BLAKE2B 1624415302696f47f799f8bd42b827bfdac7866e750ad71cca84a3c095aa39e403036d82257c864f0e4ecc1725087cc1253c73fa26928915e2c53213c3a3852a SHA512 12a094434c66f954cdd356a41123d5e6c2df8ba9aa846731ee439fd0bf330a003ca4b96c8889aef7be2e551c1d518e96c83182168049a76e9cf4ca3104533280
DIST netbox-2.7.2.tar.gz 4936914 BLAKE2B 905e2667d0637d2edb655efcba1d697eacb097ddd67c8e4586ee2a3ce5a81e4fe98a71f574ae5c732190e03e42fd4cab2f781a30622e79d5e9ea4db7c86de263 SHA512 87753ce955e296d9605e44d5f0df58c14876ca8feda3245dee166fba8a51cbfda7def8da39663570cd0e7c9195cc163d9e877b59027ea1161c7eec33702a3ea4
DIST netbox-2.7.6.tar.gz 4949672 BLAKE2B 1847e5a05493f55ca777737c11b4751bc63183d693f742c7f9b9e5d6a498fe786a60619d40394473488881e6ef922a343cacd796126b8c618158eea9ab26216d SHA512 065e9c4338fb876ac626f5dec5c98ba2ee798b2fd6d4d8a8d4e57fff4072c649e51a1db633c2718be9ca10b362e7ead9b70655fa77ae6da9f01706e60135e306
+DIST netbox-2.7.8.tar.gz 5587481 BLAKE2B 9b524ca7acc1d650402a72aa65f75d7205cf29a3a5cfa9256ff47d12f240fc38903a6db76b8cee2b923947f6e31b124ba0bfdfbf4385fb6fd027634b3b8ba675 SHA512 cce73b9bbd79725e4af01a9265c0a9f14a1ac708186123c1a90f267149157a0c174cd32d5e56875b5fdb55ef87b2ec668ec542b1d3a01256544065d6a0457b54
diff --git a/www-apps/netbox/netbox-2.7.8.ebuild b/www-apps/netbox/netbox-2.7.8.ebuild
new file mode 100644
index 000000000000..46d1a0314d0f
--- /dev/null
+++ b/www-apps/netbox/netbox-2.7.8.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="IP address and data center infrastructure management tool"
+HOMEPAGE="https://github.com/netbox-community/netbox"
+SRC_URI="https://github.com/netbox-community/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="ldap"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ acct-group/netbox
+ acct-user/netbox
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/django-2.2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-cacheops-4.2[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-cors-headers-3.2.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-debug-toolbar-2.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-filter-2.2.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-mptt-0.9.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-pglocks-1.0.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-prometheus-1.1.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-rq-2.2.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-tables2-2.2.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-taggit-1.2.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-taggit-serializer-0.1.7[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/django-timezone-field-4.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/djangorestframework-3.10.3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/drf-yasg-1.17.0[${PYTHON_MULTI_USEDEP},validation]
+ >=dev-python/jinja-2.10.3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/markdown-2.6.11[${PYTHON_MULTI_USEDEP}]
+ <dev-python/markdown-3.0.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/netaddr-0.7.19[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pillow-7.0.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/psycopg-2.8.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/py-gfm-0.1.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pycryptodome-3.9.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyyaml-5.3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/redis-py-3.3.11[${PYTHON_MULTI_USEDEP}]
+ www-servers/gunicorn[${PYTHON_MULTI_USEDEP}]
+ ldap? ( >=dev-python/django-auth-ldap-1.7[${PYTHON_MULTI_USEDEP}] )
+ ')"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.7-no-pip.patch
+ )
+
+DISABLE_AUTOFORMATTING=YES
+DOC_CONTENTS="
+netbox is installed on your system. However, there are some manual steps
+you need to complete from the installation guide [1].
+
+On Gentoo, the configuration files you need to edit are located in
+/etc/netbox, not /opt/netbox as shown in the installation guide.
+
+If this is a new installation, please follow the installation guide
+other than this difference. Also, if you need ldap, set the appropriate
+use flag when emerging netbox to install the dependency for it.
+
+Once that is done, you should be able to add the netbox service to the
+default runlevel and start it.
+
+If you want to use webhooks, you should also add the netbox-rqworker
+service to the default runlevel and start it.
+
+If this is an upgrade, follow these instructions:
+
+Stop the netbox service. If the netbox-rqworker service is running,
+stop it as well.
+
+Next, run the upgrade script as described in the upgrading guide[2].
+
+Next, check for new configuration options and set them as appropriate
+for your system.
+
+Next, start the netbox service.
+
+Finally, if you are using webhooks, start the netbox-rqworker service.
+
+[1] https://netbox.readthedocs.io/en/stable/installation/
+[2] https://netbox.readthedocs.io/en/stable/installation/upgrading/
+"
+
+src_install() {
+ dodir /opt
+ cp -a ../${P} "${ED}"/opt
+ dosym ${P} /opt/netbox
+dosym ../../etc/netbox/gunicorn_config.py /opt/netbox/gunicorn_config.py
+ dosym ../../../../etc/netbox/configuration.py \
+ /opt/netbox/netbox/netbox/configuration.py
+ dodir /etc/netbox
+ insinto /etc/netbox
+ newins netbox/netbox/configuration.example.py configuration.py
+ doins "${FILESDIR}"/gunicorn_config.py
+ fowners -R netbox:netbox /etc/netbox /opt/${P}
+ fowners -h netbox:netbox /opt/netbox
+ fperms o= /etc/netbox/configuration.py /etc/netbox/gunicorn_config.py
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newinitd "${FILESDIR}"/${PN}-rqworker.initd ${PN}-rqworker
+ keepdir /var/log/netbox
+ fowners -R netbox:netbox /var/log/netbox
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ local r
+ for r in $REPLACING_VERSIONS; do
+ if [[ $r = "2.5.10" ]]; then
+ ewarn "The home directory of the netbox user is now /var/lib/netbox"
+ ewarn "Please adjust your system."
+ fi
+ done
+}