summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-07 23:40:41 +0100
committerSam James <sam@gentoo.org>2022-09-07 23:51:29 +0100
commit7ce9609cb78bce9009841307efd5078eb2096386 (patch)
tree2842bc90ef7f4ae48ee5e27d7fed20dd8ee56cea
parentnet-misc/mobile-broadband-provider-info: Restrict tests (diff)
downloadgentoo-7ce9609c.tar.gz
gentoo-7ce9609c.tar.bz2
gentoo-7ce9609c.zip
app-text/enscript: fix implicit function declarations
Unlike normal missing includes, implicit function declaration fixes require a revbump as they can affect code generation. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/enscript/enscript-1.6.6-r1.ebuild (renamed from app-text/enscript/enscript-1.6.6.ebuild)3
-rw-r--r--app-text/enscript/files/enscript-1.6.2-implicit-function-decl.patch20
2 files changed, 22 insertions, 1 deletions
diff --git a/app-text/enscript/enscript-1.6.6.ebuild b/app-text/enscript/enscript-1.6.6-r1.ebuild
index bb889e8b0db3..f7a75d380afc 100644
--- a/app-text/enscript/enscript-1.6.6.ebuild
+++ b/app-text/enscript/enscript-1.6.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.6.4-ebuild.st.patch
"${FILESDIR}"/${PN}-1.6.5.2-php.st.patch
"${FILESDIR}"/${PN}-1.6.4-fsf-gcc-darwin.patch
+ "${FILESDIR}"/${PN}-1.6.2-implicit-function-decl.patch
)
src_prepare() {
diff --git a/app-text/enscript/files/enscript-1.6.2-implicit-function-decl.patch b/app-text/enscript/files/enscript-1.6.2-implicit-function-decl.patch
new file mode 100644
index 000000000000..90868d182023
--- /dev/null
+++ b/app-text/enscript/files/enscript-1.6.2-implicit-function-decl.patch
@@ -0,0 +1,20 @@
+https://cgit.openembedded.org/meta-openembedded/plain/meta-oe/recipes-extended/enscript/enscript/0001-getopt-Include-string.h-for-strcmp-stcncmp-functions.patch?h=master-next&id=6c251848590867debaaf87bfe12bed572d8f6a8d
+
+From faec0206611f8ea4ca6f70987866077ac8c3c6c1 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 2 Sep 2022 21:24:27 -0700
+Subject: [PATCH] getopt: Include string.h for strcmp/stcncmp functions
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/compat/getopt.c
++++ b/compat/getopt.c
+@@ -43,6 +43,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h> /* strcmp */
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C