summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-15 12:35:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-15 13:18:14 +0100
commit7ceb6132fcce7d341bc3ff4d70dc99d2d0296546 (patch)
tree8da91d4a6c3a6a2ec60e5b5815c468051bf4c863
parentdev-util/rustup: sync live (diff)
downloadgentoo-7ceb6132fcce7d341bc3ff4d70dc99d2d0296546.tar.gz
gentoo-7ceb6132fcce7d341bc3ff4d70dc99d2d0296546.tar.bz2
gentoo-7ceb6132fcce7d341bc3ff4d70dc99d2d0296546.zip
media-gfx/okularpart: Install headers to okular5 directory
Headers are required by revdeps, unfortunately not side-by-side installable by upstream, so will need conditional revdep hacking. Bug: https://bugs.gentoo.org/926748 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-gfx/okularpart/files/okularpart-23.08.5-only.patch29
-rw-r--r--media-gfx/okularpart/okularpart-23.08.5-r1.ebuild (renamed from media-gfx/okularpart/okularpart-23.08.5.ebuild)2
2 files changed, 26 insertions, 5 deletions
diff --git a/media-gfx/okularpart/files/okularpart-23.08.5-only.patch b/media-gfx/okularpart/files/okularpart-23.08.5-only.patch
index 7b62867610bf..c2712fa396c9 100644
--- a/media-gfx/okularpart/files/okularpart-23.08.5-only.patch
+++ b/media-gfx/okularpart/files/okularpart-23.08.5-only.patch
@@ -1,15 +1,18 @@
-From e3baad173b95ad75afe9d339c4a86d030b67f4be Mon Sep 17 00:00:00 2001
+From e6392d67120187d357de1a787b52aaeffeb60230 Mon Sep 17 00:00:00 2001
From: Andreas Sturmlechner <asturm@gentoo.org>
Date: Sun, 10 Mar 2024 21:37:44 +0100
Subject: [PATCH] Disable bits we don't need for okularpart only
+Install headers to okular5 to not collide with okular6, unfortunately
+this will require hacking revdeps too.
+
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
---
- CMakeLists.txt | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
+ CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index c47d6ab0f..91f25c62e 100644
+index c47d6ab0f..2e08335a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -184,7 +184,7 @@ if (BUILD_MOBILE)
@@ -30,6 +33,24 @@ index c47d6ab0f..91f25c62e 100644
endif()
add_subdirectory( generators )
+@@ -401,7 +401,7 @@ install( FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/core/version.h
+ ${CMAKE_CURRENT_BINARY_DIR}/core/okularcore_export.h
+ ${CMAKE_CURRENT_BINARY_DIR}/settings_core.h
+- DESTINATION ${KDE_INSTALL_INCLUDEDIR}/okular/core COMPONENT Devel)
++ DESTINATION ${KDE_INSTALL_INCLUDEDIR}/okular5/core COMPONENT Devel)
+
+ install( FILES
+ interfaces/configinterface.h
+@@ -409,7 +409,7 @@ install( FILES
+ interfaces/printinterface.h
+ interfaces/saveinterface.h
+ interfaces/viewerinterface.h
+- DESTINATION ${KDE_INSTALL_INCLUDEDIR}/okular/interfaces COMPONENT Devel)
++ DESTINATION ${KDE_INSTALL_INCLUDEDIR}/okular5/interfaces COMPONENT Devel)
+
+ ki18n_wrap_ui(okularcore_SRCS
+ core/chooseenginewidget.ui
--
2.44.0
diff --git a/media-gfx/okularpart/okularpart-23.08.5.ebuild b/media-gfx/okularpart/okularpart-23.08.5-r1.ebuild
index 67b16aac3538..1f3ea8ff546d 100644
--- a/media-gfx/okularpart/okularpart-23.08.5.ebuild
+++ b/media-gfx/okularpart/okularpart-23.08.5-r1.ebuild
@@ -90,5 +90,5 @@ src_configure() {
src_install() {
ecm_src_install
- rm -r "${ED}"/usr/{include,share} || die
+ rm -r "${ED}"/usr/share || die
}