summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-02 10:01:10 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-02 10:01:10 +0200
commit7cee2c736ee8c2bdd59f170b50c894cafe7dbc26 (patch)
tree2d902b8721023559b7d16c468e6239d3b21fb2da
parentdev-python/pyrex: Remove last-rited pkg (diff)
downloadgentoo-7cee2c736ee8c2bdd59f170b50c894cafe7dbc26.tar.gz
gentoo-7cee2c736ee8c2bdd59f170b50c894cafe7dbc26.tar.bz2
gentoo-7cee2c736ee8c2bdd59f170b50c894cafe7dbc26.zip
dev-python/pyvorbis: Remove last-rited pkg
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyvorbis/Manifest1
-rw-r--r--dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch65
-rw-r--r--dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch20
-rw-r--r--dev-python/pyvorbis/metadata.xml8
-rw-r--r--dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild38
-rw-r--r--profiles/package.mask5
6 files changed, 0 insertions, 137 deletions
diff --git a/dev-python/pyvorbis/Manifest b/dev-python/pyvorbis/Manifest
deleted file mode 100644
index c00b273b08aa..000000000000
--- a/dev-python/pyvorbis/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST pyvorbis-1.4.tar.gz 39045 BLAKE2B 57fe96085cfed822ee3277d59b6d8e0bb3c5b88a92c615da2159a23eab74b0ba30c693e1b3b41716c7eb4dcfbfe332956535845360a6c6b19df95c73f9634fba SHA512 c0b5ebb5d22f97b20f56a0b49e43675764fe057afa2d5de22eab9b8b73fb542186e7488cb0ba31b7af433cef1a88e815eb3e88a4609a2657ae5fba1017bdb89c
diff --git a/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch b/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch
deleted file mode 100644
index 18028dc7a8e7..000000000000
--- a/dev-python/pyvorbis/files/pyvorbis-1.4-python25.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-diff -ur pyvorbis-1.4-old/src/pyvorbiscodec.c pyvorbis-1.4/src/pyvorbiscodec.c
---- pyvorbis-1.4-old/src/pyvorbiscodec.c 2003-05-13 11:17:13.000000000 +0300
-+++ pyvorbis-1.4/src/pyvorbiscodec.c 2007-09-20 01:57:54.000000000 +0300
-@@ -118,7 +118,7 @@
- {
- vorbis_dsp_clear(PY_DSP(self));
- Py_XDECREF(((py_dsp *)self)->parent);
-- PyMem_DEL(self);
-+ PyObject_Del(self);
- }
-
- static PyObject*
-@@ -447,7 +447,7 @@
- {
- vorbis_block_clear(PY_BLOCK(self));
- Py_XDECREF(((py_block *)self)->parent);
-- PyMem_DEL(self);
-+ PyObject_Del(self);
- }
-
- static PyObject*
-diff -ur pyvorbis-1.4-old/src/pyvorbisfile.c pyvorbis-1.4/src/pyvorbisfile.c
---- pyvorbis-1.4-old/src/pyvorbisfile.c 2003-12-19 09:11:02.000000000 +0200
-+++ pyvorbis-1.4/src/pyvorbisfile.c 2007-09-20 01:59:41.000000000 +0300
-@@ -173,8 +173,7 @@
- if (ret == NULL) {
- PyMem_DEL(newobj);
- return NULL;
-- } else
-- Py_DECREF(ret);
-+ }
-
- return (PyObject *) newobj;
- }
-@@ -195,7 +194,8 @@
- fclose(py_self->c_file);
- }
-
-- PyMem_DEL(self);
-+ free(py_self->ovf);
-+ PyObject_Del(self);
- }
-
- static PyObject *
-diff -ur pyvorbis-1.4-old/src/pyvorbisinfo.c pyvorbis-1.4/src/pyvorbisinfo.c
---- pyvorbis-1.4-old/src/pyvorbisinfo.c 2003-12-19 09:51:36.000000000 +0200
-+++ pyvorbis-1.4/src/pyvorbisinfo.c 2007-09-20 02:01:58.000000000 +0300
-@@ -134,7 +134,7 @@
- static void
- py_ov_info_dealloc(PyObject *self)
- {
-- PyMem_DEL(self);
-+ PyObject_Del(self);
- }
-
- #define CMP_RET(x) \
-@@ -418,7 +418,7 @@
- free(ovc_self->vc);
- }
-
-- PyMem_DEL(self);
-+ PyObject_Del(self);
- }
-
-
diff --git a/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch b/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch
deleted file mode 100644
index 5d1d8ffc7c77..000000000000
--- a/dev-python/pyvorbis/files/pyvorbisfile.c-1.4.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/pyvorbisfile.c.orig 2003-12-19 07:11:02.000000000 +0000
-+++ src/pyvorbisfile.c 2005-09-03 20:02:19.000000000 +0100
-@@ -190,9 +190,6 @@
- /* If file was opened from a file object, decref it, so it can
- close */
- Py_DECREF(py_self->py_file);
-- } else {
-- /* Otherwise, we opened the file and should close it. */
-- fclose(py_self->c_file);
- }
-
- PyMem_DEL(self);
-@@ -260,7 +257,6 @@
-
- retval = ov_open(file, self->ovf, initial, ibytes);
-
-- self->c_file = file;
- if (retval < 0) {
- if (fname != NULL)
- fclose(file);
diff --git a/dev-python/pyvorbis/metadata.xml b/dev-python/pyvorbis/metadata.xml
deleted file mode 100644
index 9e5274c5b4ae..000000000000
--- a/dev-python/pyvorbis/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
-</maintainer>
-</pkgmetadata>
diff --git a/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild b/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild
deleted file mode 100644
index 8b1d096f03f4..000000000000
--- a/dev-python/pyvorbis/pyvorbis-1.4-r4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Python bindings for the ogg.vorbis library"
-HOMEPAGE="http://ekyo.nerim.net/software/pyogg/"
-SRC_URI="http://ekyo.nerim.net/software/pyogg/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-
-DEPEND=">=dev-python/pyogg-1.1[${PYTHON_USEDEP}]
- >=media-libs/libogg-1.0
- >=media-libs/libvorbis-1.0"
-RDEPEND="${DEPEND}"
-
-DOCS=( AUTHORS COPYING ChangeLog NEWS README )
-PATCHES=(
- "${FILESDIR}/pyvorbisfile.c-1.4.patch"
- "${FILESDIR}/${P}-python25.patch"
-)
-
-python_configure_all() {
- tc-export CC
- "${PYTHON}" config_unix.py --prefix /usr || die "Configuration failed"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- insinto /usr/share/doc/${PF}/examples
- doins test/*
-}
diff --git a/profiles/package.mask b/profiles/package.mask
index bbe6bfa45c7f..5f7593a19315 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -752,11 +752,6 @@ app-crypt/ssh-multiadd
media-gfx/printrun
# Aaron Bauman <bman@gentoo.org> (2020-08-01)
-# Py2 only. Dead upstream.
-# Removal in 30 days
-dev-python/pyvorbis
-
-# Aaron Bauman <bman@gentoo.org> (2020-08-01)
# Py2 only. Last upstream release 2013.
# Removal in 30 days. Last 2 have deps on cddb.
<media-sound/jack-4.0.0_pre