summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-06-25 20:09:01 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-06-25 20:09:01 -0400
commit7d0a5b8014b5383d061ae6da0183d438c9ad0bf9 (patch)
tree1d3281474031950f86712bf3e9462cbe37c6afc6
parentdev-libs/opensc: add libressl support (diff)
downloadgentoo-7d0a5b80.tar.gz
gentoo-7d0a5b80.tar.bz2
gentoo-7d0a5b80.zip
dev-libs/skyutils: add libressl support
Package-Manager: portage-2.2.28
-rw-r--r--dev-libs/skyutils/skyutils-2.8-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/skyutils/skyutils-2.8-r3.ebuild b/dev-libs/skyutils/skyutils-2.8-r3.ebuild
new file mode 100644
index 000000000000..907888086449
--- /dev/null
+++ b/dev-libs/skyutils/skyutils-2.8-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="Library of assorted C utility functions"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage" # was "http://zekiller.skytech.org/coders_en.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl ssl"
+
+DEPEND="ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+)"
+
+src_prepare() {
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
+ epatch "${FILESDIR}"/${P}-libs.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-flags -D_GNU_SOURCE
+ econf `use_enable ssl` || die "./configure failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog
+}