summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-16 02:50:37 +0100
committerSam James <sam@gentoo.org>2023-05-16 02:52:20 +0100
commit7d30eab6e802ebc2fe427d30e220b3c92cb17908 (patch)
tree6468324b0d04dceef280982973ea2455a1af5d91
parentsys-block/nbdkit: add Valgrind support (diff)
downloadgentoo-7d30eab6e802ebc2fe427d30e220b3c92cb17908.tar.gz
gentoo-7d30eab6e802ebc2fe427d30e220b3c92cb17908.tar.bz2
gentoo-7d30eab6e802ebc2fe427d30e220b3c92cb17908.zip
sys-block/fio: add Valgrind annotation support
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-block/fio/fio-3.34.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-block/fio/fio-3.34.ebuild b/sys-block/fio/fio-3.34.ebuild
index 7ca26eaf225e..b090ea6b924f 100644
--- a/sys-block/fio/fio-3.34.ebuild
+++ b/sys-block/fio/fio-3.34.ebuild
@@ -17,7 +17,7 @@ SRC_URI="https://brick.kernel.dk/snaps/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm ~arm64 ~ia64 ~loong ~ppc ppc64 ~riscv x86"
-IUSE="aio curl glusterfs gnuplot gtk io-uring nfs numa python rbd rdma static tcmalloc test zbc zlib"
+IUSE="aio curl glusterfs gnuplot gtk io-uring nfs numa python rbd rdma static tcmalloc test valgrind zbc zlib"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
gnuplot? ( python )
io-uring? ( aio )"
@@ -48,7 +48,8 @@ RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
gtk? ( x11-libs/gtk+:2 )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )
- test? ( dev-util/cunit )"
+ test? ( dev-util/cunit )
+ valgrind? ( dev-util/valgrind )"
RDEPEND+="
python? (
${PYTHON_DEPS}
@@ -74,6 +75,7 @@ src_prepare() {
-e '/if compile_prog "" "-lz" "zlib" *; *then/ '"s::if $(usex zlib true false) ; then:" \
-e '/if compile_prog "" "-laio" "libaio" *; *then/'"s::if $(usex aio true false) ; then:" \
-e '/if compile_prog "" "-lcunit" "CUnit" *; *then/'"s::if $(usex test true false) ; then:" \
+ -e '/if compile_prog "" "" "valgrind_dev" *; *then/'"s::if $(usex valgrind true false) ; then:" \
configure || die
}