summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-03-27 10:20:18 +0100
committerMatthew Smith <matthew@gentoo.org>2022-03-27 10:24:39 +0100
commit7d32094dfd23af9eaae8a4e9c49d7a35485fade6 (patch)
tree511c837d2c5ebdebba379a970f1b1b6cc71983d8
parentapp-emacs/helm: add 3.8.5 (diff)
downloadgentoo-7d32094d.tar.gz
gentoo-7d32094d.tar.bz2
gentoo-7d32094d.zip
app-emacs/ghub: add 3.5.6
Signed-off-by: Matthew Smith <matthew@gentoo.org>
-rw-r--r--app-emacs/ghub/Manifest1
-rw-r--r--app-emacs/ghub/ghub-3.5.6.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-emacs/ghub/Manifest b/app-emacs/ghub/Manifest
index 6c06ce8a1c59..2e322c66bf73 100644
--- a/app-emacs/ghub/Manifest
+++ b/app-emacs/ghub/Manifest
@@ -1 +1,2 @@
DIST ghub-3.5.4.tar.gz 58088 BLAKE2B 5ee6fe56455e8f12e7be8c1ae705a426677fab0b9a5da8f42c4b331bdd635120a2f5475055c9e98c8df01b259f76aa2dd4cad6e8b4562481d261bb7802b826f6 SHA512 df8ba56195ae3773c0c8c8a8f555e562b04de59ce3fb1c17c24ca3b10418299555326f0a9360eb47725310890e31f73221eece3ca1ff83e47d52941e224fc562
+DIST ghub-3.5.6.tar.gz 59474 BLAKE2B c27610f24526a40b5f36d2f5154c0eeb9f86e9da676baa82b2866a0bb58de8a78736d56a5d6454666b539774abbf5dfcd260880aa07499616f44a3e2c8315999 SHA512 6c6724978f0809a4977cc7965de4c33eaf29537c13507aabffecae4a7d2b3710074179d819aee1a54fce8f12e20db46b18466c3f1012d3b9c41eae3c2fade58a
diff --git a/app-emacs/ghub/ghub-3.5.6.ebuild b/app-emacs/ghub/ghub-3.5.6.ebuild
new file mode 100644
index 000000000000..64e656791e15
--- /dev/null
+++ b/app-emacs/ghub/ghub-3.5.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+NEED_EMACS=25
+
+inherit elisp
+
+DESCRIPTION="Minuscule client library for the Git forge APIs"
+HOMEPAGE="https://magit.vc/manual/ghub"
+SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+SITEFILE="50${PN}-gentoo.el"
+ELISP_TEXINFO="docs/ghub.texi"
+DOCS="README.md"
+
+RDEPEND="
+ >=app-emacs/treepy-0.1.1
+"
+BDEPEND="${RDEPEND}
+ sys-apps/texinfo"
+
+src_prepare() {
+ default
+ mv lisp/*.el . || die
+ rm ghub-pkg.el || die
+}