summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:15:55 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:44:33 -0500
commit7d55d511c8c8f67318d7386eb91c2dfadb3e9021 (patch)
tree2e947788b626ad44f61ff5ec61a19a6275b36ab3
parentdev-python/oslo-service: 1.31.8 bump (diff)
downloadgentoo-7d55d511.tar.gz
gentoo-7d55d511.tar.bz2
gentoo-7d55d511.zip
dev-python/oslo-service: 1.31.8 stable amd64/x86 with cleanup
fixes signal handling in python3 (eventlet stuff) Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-python/oslo-service/Manifest1
-rw-r--r--dev-python/oslo-service/oslo-service-1.31.7.ebuild63
-rw-r--r--dev-python/oslo-service/oslo-service-1.31.8.ebuild2
3 files changed, 1 insertions, 65 deletions
diff --git a/dev-python/oslo-service/Manifest b/dev-python/oslo-service/Manifest
index bb7d343bef83..18f565c21ed0 100644
--- a/dev-python/oslo-service/Manifest
+++ b/dev-python/oslo-service/Manifest
@@ -1,2 +1 @@
-DIST oslo.service-1.31.7.tar.gz 72069 BLAKE2B 8a40608ba3b4ab8c78cc48f89607af5db3e493aaec48e4b33d917fd5ea32478dc04a0ccb2f1aec524acc900a13d9880d8bd51e49bd3b2eab787d7b7c55872e47 SHA512 18bd558cbbf67441438f62a212ca61affd625597a02cbe8948bf055e61887a0e1b21dfc18e7450ec21951377daabcda8e5e7f57b39f5dcaa1b1d635df13f8e21
DIST oslo.service-1.31.8.tar.gz 72731 BLAKE2B d0460fa76df75b691dd85bed07b2bff5f8574feb84f324736769156fb1d9c74f181d8267ed69b6f8a371bd9eae3db17d5fc8588bd706da30f3cd065e8d35f80b SHA512 af4f1fc011dce56935d8ce09902172fe3c93f4907023d04c3aacb3e06631b5d5fc891ec55ee3c42acb8e29754a7519d12a38d1264935636284aee9134ce6f84f
diff --git a/dev-python/oslo-service/oslo-service-1.31.7.ebuild b/dev-python/oslo-service/oslo-service-1.31.7.ebuild
deleted file mode 100644
index 1826f7701238..000000000000
--- a/dev-python/oslo-service/oslo-service-1.31.7.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Library for running OpenStack services"
-HOMEPAGE="https://pypi.org/project/oslo.service/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.service/oslo.service-${PV}.tar.gz"
-S="${WORKDIR}/oslo.service-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
- >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/doc8-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- >=dev-python/greenlet-0.4.10[${PYTHON_USEDEP}]
- >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-concurrency-3.25.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
- >=dev-python/routes-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/paste-2.0.2[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}
diff --git a/dev-python/oslo-service/oslo-service-1.31.8.ebuild b/dev-python/oslo-service/oslo-service-1.31.8.ebuild
index 2a0093adb6f1..1826f7701238 100644
--- a/dev-python/oslo-service/oslo-service-1.31.8.ebuild
+++ b/dev-python/oslo-service/oslo-service-1.31.8.ebuild
@@ -13,7 +13,7 @@ S="${WORKDIR}/oslo.service-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="test"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]