summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-04 15:19:24 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-04 15:58:50 +0200
commit7d56ff3ae75ad74adcefd5288c5f5fe4a5d6b5a1 (patch)
tree4609de2565437463dba87a4a19986e91fef88421
parentapp-crypt/acme-sh: drop old version (diff)
downloadgentoo-7d56ff3ae75ad74adcefd5288c5f5fe4a5d6b5a1.tar.gz
gentoo-7d56ff3ae75ad74adcefd5288c5f5fe4a5d6b5a1.tar.bz2
gentoo-7d56ff3ae75ad74adcefd5288c5f5fe4a5d6b5a1.zip
distutils-r1.eclass: Forbid .hypothesis in site-packages too
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--eclass/distutils-r1.eclass5
1 files changed, 4 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 2994993e63e8..a02b6d059bd1 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -861,7 +861,10 @@ distutils-r1_python_install() {
esetup.py install --skip-build --root="${root}" "${args[@]}"
- local forbidden_package_names=( examples test tests .pytest_cache )
+ local forbidden_package_names=(
+ examples test tests
+ .pytest_cache .hypothesis
+ )
local p
for p in "${forbidden_package_names[@]}"; do
if [[ -d ${root}$(python_get_sitedir)/${p} ]]; then