summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-06 10:06:59 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-06 10:06:59 +0100
commit7d66008e865da7d97da7ba991519e51ca57369b8 (patch)
tree4fded8ac67a13bc3ce489a36a0984717a5a973a3
parentdev-libs/libffi: remove userland_BSD (diff)
downloadgentoo-7d66008e.tar.gz
gentoo-7d66008e.tar.bz2
gentoo-7d66008e.zip
dev-libs/libiconv: remove userland_GNU
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/libiconv/libiconv-1.15.ebuild21
-rw-r--r--dev-libs/libiconv/libiconv-1.16.ebuild21
2 files changed, 16 insertions, 26 deletions
diff --git a/dev-libs/libiconv/libiconv-1.15.ebuild b/dev-libs/libiconv/libiconv-1.15.ebuild
index d6a93da72c86..6180c813ce14 100644
--- a/dev-libs/libiconv/libiconv-1.15.ebuild
+++ b/dev-libs/libiconv/libiconv-1.15.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
@@ -15,8 +15,7 @@ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ~ppc64 ~s390 ~spar
IUSE="prefix static-libs"
DEPEND="!sys-libs/glibc
- !sys-libs/musl
- !userland_GNU? ( !sys-apps/man-pages )"
+ !sys-libs/musl"
RDEPEND="${DEPEND}"
PATCHES=(
@@ -53,14 +52,10 @@ multilib_src_install_all() {
# can depend on this
gen_usr_ldscript -a iconv charset
- # If we have a GNU userland, we probably have sys-apps/man-pages
- # installed, which means we want to rename our copies #503162.
- # The use of USELAND=GNU is kind of a hack though ...
- if use userland_GNU ; then
- cd "${ED}"/usr/share/man || die
- local f
- for f in man*/*.[0-9] ; do
- mv "${f}" "${f%/*}/${PN}-${f#*/}" || die
- done
- fi
+ # we need to rename our copies #503162
+ cd "${ED}"/usr/share/man || die
+ local f
+ for f in man*/*.[0-9] ; do
+ mv "${f}" "${f%/*}/${PN}-${f#*/}" || die
+ done
}
diff --git a/dev-libs/libiconv/libiconv-1.16.ebuild b/dev-libs/libiconv/libiconv-1.16.ebuild
index 6962ed176257..346661c34d79 100644
--- a/dev-libs/libiconv/libiconv-1.16.ebuild
+++ b/dev-libs/libiconv/libiconv-1.16.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,8 +15,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
IUSE="prefix static-libs"
DEPEND="!sys-libs/glibc
- !sys-libs/musl
- !userland_GNU? ( !sys-apps/man-pages )"
+ !sys-libs/musl"
RDEPEND="${DEPEND}"
PATCHES=(
@@ -44,14 +43,10 @@ multilib_src_configure() {
multilib_src_install_all() {
use static-libs || find "${ED}" -name 'lib*.la' -delete
- # If we have a GNU userland, we probably have sys-apps/man-pages
- # installed, which means we want to rename our copies #503162.
- # The use of USELAND=GNU is kind of a hack though ...
- if use userland_GNU ; then
- cd "${ED}"/usr/share/man || die
- local f
- for f in man*/*.[0-9] ; do
- mv "${f}" "${f%/*}/${PN}-${f#*/}" || die
- done
- fi
+ # we need to rename our copies #503162
+ cd "${ED}"/usr/share/man || die
+ local f
+ for f in man*/*.[0-9] ; do
+ mv "${f}" "${f%/*}/${PN}-${f#*/}" || die
+ done
}