summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 08:46:37 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 08:49:04 +0100
commit7d8e2b7445d1daaca8fd21f94e933643ccd07534 (patch)
tree64a814c944c36336f293b9094ade72dfc3ef1990
parentdev-python/unicodecsv: EAPI 8, PEP517 (diff)
downloadgentoo-7d8e2b74.tar.gz
gentoo-7d8e2b74.tar.bz2
gentoo-7d8e2b74.zip
dev-python/jellyfish: Switch to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jellyfish/jellyfish-0.9.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/jellyfish/jellyfish-0.9.0-r1.ebuild b/dev-python/jellyfish/jellyfish-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..144312e581c6
--- /dev/null
+++ b/dev-python/jellyfish/jellyfish-0.9.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for doing approximate and phonetic matching of strings"
+HOMEPAGE="https://github.com/jamesturk/jellyfish https://pypi.org/project/jellyfish/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/unicodecsv[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ rm -r jellyfish || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ epytest --pyargs jellyfish.test
+}