summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-12-01 11:40:57 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-12-01 11:44:54 -0600
commit7d9fe9fd912296eb4890ecce1df360a1b882d6ec (patch)
treee7b85c61a45bb9e1af44ca449eb382286b7a919f
parentmedia-libs/alsa-ucm-conf: Stabilize 1.2.10-r1 arm64, #918919 (diff)
downloadgentoo-7d9fe9fd912296eb4890ecce1df360a1b882d6ec.tar.gz
gentoo-7d9fe9fd912296eb4890ecce1df360a1b882d6ec.tar.bz2
gentoo-7d9fe9fd912296eb4890ecce1df360a1b882d6ec.zip
app-containers/skopeo: 1.14.0-r2 revbump to fix src_install
- drop makefile patch - only install things that are not in app-containers/containers-common Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-containers/skopeo/skopeo-1.14.0-r2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-containers/skopeo/skopeo-1.14.0-r2.ebuild b/app-containers/skopeo/skopeo-1.14.0-r2.ebuild
new file mode 100644
index 000000000000..2aed06a521af
--- /dev/null
+++ b/app-containers/skopeo/skopeo-1.14.0-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module linux-info
+
+DESCRIPTION="Work with remote container images registries"
+HOMEPAGE="https://github.com/containers/skopeo"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/skopeo.git"
+else
+ SRC_URI="https://github.com/containers/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+# main
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT"
+SLOT="0"
+IUSE="btrfs device-mapper rootless"
+
+COMMON_DEPEND="
+ >=app-crypt/gpgme-1.5.5:=
+ >=dev-libs/libassuan-2.4.3:=
+ btrfs? ( >=sys-fs/btrfs-progs-4.0.1 )
+ device-mapper? ( >=sys-fs/lvm2-2.02.145:= )
+ rootless? ( sys-apps/shadow:= )
+"
+
+# TODO: Is this really needed? cause upstream doesnt mention it https://github.com/containers/skopeo/blob/main/install.md#building-from-source
+# dev-libs/libgpg-error:=
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="
+ ${COMMON_DEPEND}
+ app-containers/containers-common
+"
+BDEPEND="dev-go/go-md2man"
+
+RESTRICT="test"
+
+pkg_setup() {
+ use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
+ use device-mapper && CONFIG_CHECK+=" ~MD"
+ linux-info_pkg_setup
+}
+
+run_make() {
+ emake \
+ BTRFS_BUILD_TAG="$(usex btrfs '' 'btrfs_noversion exclude_graphdriver_btrfs')" \
+ CONTAINERSCONFDIR="${EPREFIX}/etc/containers" \
+ LIBDM_BUILD_TAG=$(usex device-mapper '' libdm_no_deferred_remove) \
+ LIBSUBID_BUILD_TAG=$(usex rootless 'libsubid' '') \
+ PREFIX="${EPREFIX}/usr" \
+ $@
+}
+
+src_compile() {
+ run_make all completions
+}
+
+src_install() {
+ # The install target in the Makefile tries to rebuild the binary and
+ # installs things that are already installed by containers-common.
+ dobin bin/skopeo
+dodoc README.md
+ doman docs/*.1
+ run_make "DESTDIR=${D}" install-completions
+}