summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-26 23:23:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-27 01:12:47 +0100
commit7de4915e9c99fba07343fc33c4bf50c85b2b7c76 (patch)
treed8a76cf0d0ea57cc5ad73ad7d2670fb5727c882e
parentmedia-libs/vigra: Disable test dir to avoid useless warnings (diff)
downloadgentoo-7de4915e.tar.gz
gentoo-7de4915e.tar.bz2
gentoo-7de4915e.zip
media-libs/vigra: Fix build with sphinx-2
See also: https://github.com/ukoethe/vigra/issues/462 Closes: https://bugs.gentoo.org/678308 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch27
-rw-r--r--media-libs/vigra/vigra-1.11.1-r2.ebuild1
-rw-r--r--media-libs/vigra/vigra-9999.ebuild6
3 files changed, 33 insertions, 1 deletions
diff --git a/media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch b/media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch
new file mode 100644
index 000000000000..fc265763f6ad
--- /dev/null
+++ b/media-libs/vigra/files/vigra-1.11.1-sphinx.ext.pngmath.patch
@@ -0,0 +1,27 @@
+Description: Replace sphinx.ext.pngmath by sphinx.ext.imgmath to build with sphinx 1.8
+Bug-Debian: https://bugs.debian.org/923467
+Author: Andreas Tille <tille@debian.org>
+Last-Update: Fri, 08 Mar 2019 18:38:02 +0100
+
+--- a/vigranumpy/docsrc/conf.py.cmake2.in
++++ b/vigranumpy/docsrc/conf.py.cmake2.in
+@@ -59,7 +59,7 @@ os.environ['PATH'] = os.pathsep.join([vi
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.pngmath']
++extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.imgmath']
+
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['_templates']
+--- a/vigranumpy/docsrc/conf.py.in
++++ b/vigranumpy/docsrc/conf.py.in
+@@ -58,7 +58,7 @@ os.environ['PATH'] = os.pathsep.join([vi
+
+ # Add any Sphinx extension module names here, as strings. They can be extensions
+ # coming with Sphinx (named 'sphinx.ext.*') or your custom ones.
+-extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.pngmath']
++extensions = ['sphinx.ext.autodoc', 'sphinx.ext.todo', 'sphinx.ext.coverage', 'sphinx.ext.imgmath']
+
+ # Add any paths that contain templates here, relative to this directory.
+ templates_path = ['_templates']
diff --git a/media-libs/vigra/vigra-1.11.1-r2.ebuild b/media-libs/vigra/vigra-1.11.1-r2.ebuild
index 8f4b2b23a1c5..757fe839d198 100644
--- a/media-libs/vigra/vigra-1.11.1-r2.ebuild
+++ b/media-libs/vigra/vigra-1.11.1-r2.ebuild
@@ -69,6 +69,7 @@ PATCHES=(
"${FILESDIR}/${P}-boost-python.patch"
# TODO: upstream
"${FILESDIR}/${P}-lib_suffix.patch"
+ "${FILESDIR}/${P}-sphinx.ext.pngmath.patch" # thanks to Debian; bug 678308
)
pkg_setup() {
diff --git a/media-libs/vigra/vigra-9999.ebuild b/media-libs/vigra/vigra-9999.ebuild
index cad2a8191a7b..6d9d2266b163 100644
--- a/media-libs/vigra/vigra-9999.ebuild
+++ b/media-libs/vigra/vigra-9999.ebuild
@@ -64,7 +64,11 @@ RDEPEND="${PYTHON_DEPS}
# Severely broken, also disabled in Fedora, bugs #390447, #653442
RESTRICT="test"
-PATCHES=( "${FILESDIR}/${PN}-1.11.1-lib_suffix.patch" )
+PATCHES=(
+ # TODO: upstream
+ "${FILESDIR}/${PN}-1.11.1-lib_suffix.patch"
+ "${FILESDIR}/${PN}-1.11.1-sphinx.ext.pngmath.patch" # thanks to Debian; bug 678308
+)
pkg_setup() {
if use python || use doc; then