summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-29 05:17:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-29 05:35:43 +0100
commit7df11bb8de116c3ba9917786974c4f98e6a5a165 (patch)
tree48c07601969f8b82aeeb746fc8be8f589c0820d0
parentdev-python/rpds-py: Bump to 0.16.2 (diff)
downloadgentoo-7df11bb8.tar.gz
gentoo-7df11bb8.tar.bz2
gentoo-7df11bb8.zip
dev-python/fastjsonschema: Bump to 2.19.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 4da7cd5f9bc7..3b5ab4ef04f1 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST fastjsonschema-2.19.0.tar.gz 371202 BLAKE2B 56103ae94d52a337ceb830b7dfe68b3e1c3d5bdfbe46c8c042b5bc1a6d4e36201176a274135779cbf50a9ce939d95f5bd3c5bd88b7a6483db4cc438bff1d986a SHA512 d26c7f44acfeb4210fad188e3fe5486231a516fb0a4fa7d756dd9d1378b22afd7b4acb6b34085cabcfe31dac44a605de6f90a158a3af69de97f8926d59b3a105
+DIST fastjsonschema-2.19.1.tar.gz 372732 BLAKE2B f028e027483e02969c4d750a888659add9dd7f661776ab42242f74492272267b93a2248cdc50b78389091cc1a1fd7661abbf377d81edf73df35ed1e222be7328 SHA512 b276788ebe1d3a6bc5d1463c2a4940fbe5c9e0a7919c813b78f385faa406527cac34d4042e6a69e0ca1631f3e5ed0bc351e13d9d1e245132a1607e010a5a2346
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild
new file mode 100644
index 000000000000..e1529c815ca6
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.19.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)