summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSiva Mahadevan <me@svmhdvn.name>2023-09-30 16:40:36 +0000
committerMatt Turner <mattst88@gentoo.org>2023-10-09 12:18:17 -0400
commit7e40e77a79d7b638754ebbeab847d26a083fbb3d (patch)
treee87bab4bbd4a890ffddfbcd9af4915868a5f753f
parentdev-libs/libcpuid: add 0.6.4 (diff)
downloadgentoo-7e40e77a79d7b638754ebbeab847d26a083fbb3d.tar.gz
gentoo-7e40e77a79d7b638754ebbeab847d26a083fbb3d.tar.bz2
gentoo-7e40e77a79d7b638754ebbeab847d26a083fbb3d.zip
media-libs/libva: add 2.20.0
Signed-off-by: Siva Mahadevan <me@svmhdvn.name> Closes: https://github.com/gentoo/gentoo/pull/33140 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-libs/libva/Manifest1
-rw-r--r--media-libs/libva/libva-2.20.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/libva/Manifest b/media-libs/libva/Manifest
index 2be4b7172dde..fc8072e34454 100644
--- a/media-libs/libva/Manifest
+++ b/media-libs/libva/Manifest
@@ -1,2 +1,3 @@
DIST libva-2.18.0.tar.gz 278493 BLAKE2B 619a1dcb9aaa71b38ec7be500adf6b526f50ae20fa76d1c5ac750229e03a2d5b82dabe334cf07c0f539c1b079829f2ec000ce6570e05e6e18fbf7415c5d5b9b3 SHA512 12e8d837604d2f354d849a8adc84281ae1ecfd2433f1b7dc8e28b5d703ada42b4a84b2b3870e8d2397b77d0d9741afe3bc04d25b4426531805aeb72defaac7ad
DIST libva-2.19.0.tar.gz 279536 BLAKE2B 85b60819b2a02aeb895c0608aa56d3d31f2c1c9db960ec9688b2af177cafad3b37e4f23f9ab9c952b7dd107233be57406f71edbcc5d7a5bbc3f5a6afece80c39 SHA512 04976f84487abac1a194a7ace9f698bb01eed04369e027351f63e07ced8694dbbe45511965e7775a6d8a701d6ad61fe6d57a23ee8c9b0d99089d5108657d018c
+DIST libva-2.20.0.tar.gz 280079 BLAKE2B bb1b7f8757d068765fa69e57e8747e0bbd61ea0874bd42d27e0a99786cad2a4a81d7c20a28ff977cebcef54cd8cafa6c0493c18b563ad1ab47a9c3190d0cd1c6 SHA512 85f4aa6b6e9173d407ca3987745f985d0f898091f14c947a928b6db662a03b5cfe82483901690d81618697fe17a2c41ff6694a611f3654d5ab06840da987e40d
diff --git a/media-libs/libva/libva-2.20.0.ebuild b/media-libs/libva/libva-2.20.0.ebuild
new file mode 100644
index 000000000000..4f264beeabed
--- /dev/null
+++ b/media-libs/libva/libva-2.20.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib optfeature
+
+DESCRIPTION="Video Acceleration (VA) API for Linux"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
+ EGIT_BRANCH=master
+ EGIT_REPO_URI="https://github.com/intel/libva"
+else
+ SRC_URI="https://github.com/intel/libva/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~mips ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1)"
+IUSE="wayland X"
+
+RDEPEND="
+ >=x11-libs/libdrm-2.4.60[${MULTILIB_USEDEP}]
+ wayland? (
+ >=dev-libs/wayland-1.11[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:=[${MULTILIB_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ wayland? ( dev-util/wayland-scanner )
+ virtual/pkgconfig
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/va/va_x11.h
+ /usr/include/va/va_dri2.h
+ /usr/include/va/va_dricommon.h
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddriverdir="${EPREFIX}/usr/$(get_libdir)/va/drivers"
+ -Ddisable_drm=false
+ -Dwith_x11=$(usex X)
+ -Dwith_glx=no
+ -Dwith_wayland=$(usex wayland)
+ -Denable_docs=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ optfeature_header
+ optfeature "Older Intel GPU support up to Gen8" media-libs/libva-intel-driver
+ optfeature "Newer Intel GPU support from Gen9+" media-libs/libva-intel-media-driver
+}