summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEsteve Varela Colominas <esteve.varela@gmail.com>2021-09-16 03:05:18 +0200
committerSam James <sam@gentoo.org>2021-09-16 02:25:04 +0100
commit7e4731691bf7d76ad6530951e10fb3954e16c9d8 (patch)
tree6a2cb0d83c8a4d841b2b414aff08cddd64d178e5
parentkde-plasma/plasma-meta: Stabilize 5.22.5 arm64, #811444 (diff)
downloadgentoo-7e473169.tar.gz
gentoo-7e473169.tar.bz2
gentoo-7e473169.zip
sci-libs/libsigrokdecode: Pick the right python3-embed version
Closes: https://bugs.gentoo.org/794592 Closes: https://bugs.gentoo.org/799614 Signed-off-by: Esteve Varela Colominas <esteve.varela@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-libs/libsigrokdecode/libsigrokdecode-0.5.3-r1.ebuild (renamed from sci-libs/libsigrokdecode/libsigrokdecode-0.5.3.ebuild)20
-rw-r--r--sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild18
2 files changed, 17 insertions, 21 deletions
diff --git a/sci-libs/libsigrokdecode/libsigrokdecode-0.5.3.ebuild b/sci-libs/libsigrokdecode/libsigrokdecode-0.5.3-r1.ebuild
index 64dcf8d7c68f..94adf3d75fe7 100644
--- a/sci-libs/libsigrokdecode/libsigrokdecode-0.5.3.ebuild
+++ b/sci-libs/libsigrokdecode/libsigrokdecode-0.5.3-r1.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit python-single-r1
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit autotools python-single-r1
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
- inherit git-r3 autotools
+ inherit git-r3
else
SRC_URI="https://sigrok.org/download/source/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -32,17 +32,15 @@ BDEPEND="
src_prepare() {
default
- [[ ${PV} == *9999* ]] && eautoreconf
- # Only a test program (not installed, and not used by src_test)
- # is used by libsigrok, so disable it to avoid the compile.
- sed -i \
- -e '/build_runtc=/s:yes:no:' \
- configure || die
+ # bug #794592
+ sed -i -e 's/\[SRD_PKGLIBS\],$/& [python3-embed], [python3],/' configure.ac || die
+
+ eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf $(use_enable static-libs static) PYTHON3="${PYTHON}"
}
src_test() {
diff --git a/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild b/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
index a5914c13031c..71b414a4c1ad 100644
--- a/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
+++ b/sci-libs/libsigrokdecode/libsigrokdecode-9999.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
-inherit python-single-r1
+PYTHON_COMPAT=( python3_{8,9,10} )
+inherit autotools python-single-r1
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
- inherit git-r3 autotools
+ inherit git-r3
else
SRC_URI="https://sigrok.org/download/source/${PN}/${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
@@ -32,17 +32,15 @@ BDEPEND="
src_prepare() {
default
- [[ ${PV} == *9999* ]] && eautoreconf
- # Only a test program (not installed, and not used by src_test)
- # is used by libsigrok, so disable it to avoid the compile.
- sed -i \
- -e '/build_runtc=/s:yes:no:' \
- configure || die
+ # bug #794592
+ sed -i -e 's/\[SRD_PKGLIBS\],$/& [python3-embed], [python3],/' configure.ac || die
+
+ eautoreconf
}
src_configure() {
- econf $(use_enable static-libs static)
+ econf $(use_enable static-libs static) PYTHON3="${PYTHON}"
}
src_test() {