summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-10-07 17:51:02 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-08 13:51:11 +0200
commit7e477043604074419ab0cbee02e9fde699369b35 (patch)
tree6499ff333876c2383e44e520da589c364a45bc96
parentdev-libs/tree-sitter-javascript: fix SRC_URI (diff)
downloadgentoo-7e477043.tar.gz
gentoo-7e477043.tar.bz2
gentoo-7e477043.zip
app-accessibility/orca: Version bump to 45.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33238 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--app-accessibility/orca/Manifest1
-rw-r--r--app-accessibility/orca/orca-45.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index bcd4a9f29830..b5c4ede72462 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,2 +1,3 @@
DIST orca-44.1.tar.xz 3760772 BLAKE2B 1e2825e9183b86563d85f106f80b7fa84d7d0cc06c818cb72c2a307c9c85a421cbbfc581df7829afde558ddf468bc048382d059ae995661a5163d390585961b4 SHA512 951a60b7efd9b61762404c20b62d476c1ebc3fc2662c0be1feef307fa1761feb5195c89ce725db1585dde4c39d96e1aa74c2b5c934115a3c2669880c3c7ac200
DIST orca-45.0.tar.xz 3949908 BLAKE2B 135dff79cda2a1a116256f2c1b68a40d29b17e5507fd3407d61dfc2478339aab1d7627c3aaac5f388a0140008e8a492820f0e56caac7ea83216c50f4f3fa32d8 SHA512 3213d5f0b8e0eacc5daad3df3e521548c5e6dd5ad8584e50d60a7fd054fee86793e956d3db3dcdc223d34d72bcfbfa0b436bc40f6e965528eafa2abf36259c83
+DIST orca-45.1.tar.xz 3966196 BLAKE2B 5d78e228c480e880ca62f5e6b35d5394cbe41b67dc14f7158ca3dcadcd9721bb6e37f2054c1fa3375019351fc609d1ab4268becede10b60fbc67051c5e67539f SHA512 581126ced85943c916d9b2c0a55c12fe16344c9d6501be0290698c0668909faab4c1f539ffd856c82d0b386cfa8ca00ba5176ff5b9c5c1176cc30faededb411a
diff --git a/app-accessibility/orca/orca-45.1.ebuild b/app-accessibility/orca/orca-45.1.ebuild
new file mode 100644
index 000000000000..155fb4e4a562
--- /dev/null
+++ b/app-accessibility/orca/orca-45.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.48:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.46[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}