summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-25 07:38:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-25 09:12:14 +0200
commit7e5195ccad29917b5704eee1f015685460f69ab7 (patch)
treeb2646dc4001fca268f0e31956c6bfb17f3ec85af
parentdev-python/sphinx: Bump to 5.1.0 (diff)
downloadgentoo-7e5195cc.tar.gz
gentoo-7e5195cc.tar.bz2
gentoo-7e5195cc.zip
dev-python/weasyprint: Bump to 56.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-56.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 87da0fe6ebfe..815a722af43a 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,2 +1,3 @@
DIST weasyprint-55.0.tar.gz 410970 BLAKE2B ba77f249c3568031eff9b7110864b69113f71ea197d0c7136de01bd40155a437b5e540e87219e6ca49428b98d8ec471dcf9ed1d0224d68a3b320e5fffb568239 SHA512 96cc6de5af86da47aa0b5a84c3f00679690774574f3370ca319afe77f3eb9c9725f3b0a6cbddf589f23f444972bc77b07cce7e27ee2c466484636b3cb30250a3
DIST weasyprint-56.0.tar.gz 419236 BLAKE2B c64d382e4ac169904a51fec17152faacccf4ccdab775a3b34b0db7e0a4306e6cadf6810482cee5535991400455864749cce1fc6ba5e0b469a3eb934d62298028 SHA512 d8efc83f77967a514d26806a9b73ef03e047431c6db9b367cd23a819b4a68714d216081afc74162b60084d0f3755498dc782d0335069bc9e70c42b611b737eec
+DIST weasyprint-56.1.tar.gz 420035 BLAKE2B ac6ff4fae70406c125f8e5c959acba297fa92644dd6a69a95af0192260c6fc8890b1ae790c25eb16f79a3f527a88e4912787c8d29f4ea213c2fc4ecab589ecf8 SHA512 c64bcef9789cb8c52853cfe02f5249240b67fa8368f3467c0e56cefe8ee9fde3dc9a1a489278e7238ed7fddfebba2f238f37245a3ef4d7482a32cee14dbf66b0
diff --git a/dev-python/weasyprint/weasyprint-56.1.ebuild b/dev-python/weasyprint/weasyprint-56.1.ebuild
new file mode 100644
index 000000000000..dd405c38ee37
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-56.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="https://weasyprint.org https://github.com/Kozea/WeasyPrint"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ <app-text/ghostscript-gpl-9.56
+ media-fonts/ahem
+ media-fonts/dejavu
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}