summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-08-17 00:08:26 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-08-17 00:08:44 +0200
commit7e5cb6a88847716538e95d36958aac7f630c7921 (patch)
tree523b634861742920f07fb51c4cb12b16a5875195
parentdev-libs/cglm: add 0.9.1 (diff)
downloadgentoo-7e5cb6a88847716538e95d36958aac7f630c7921.tar.gz
gentoo-7e5cb6a88847716538e95d36958aac7f630c7921.tar.bz2
gentoo-7e5cb6a88847716538e95d36958aac7f630c7921.zip
x11-misc/grsync: add 1.3.1
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--x11-misc/grsync/Manifest1
-rw-r--r--x11-misc/grsync/grsync-1.3.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/grsync/Manifest b/x11-misc/grsync/Manifest
index 022f1de4f644..34c75a3e0a8d 100644
--- a/x11-misc/grsync/Manifest
+++ b/x11-misc/grsync/Manifest
@@ -1 +1,2 @@
DIST grsync-1.3.0.tar.gz 304725 BLAKE2B 4e58eb7db8082b733468b95db995a2e7f7f970cebe2b3eb614e0a828d2fb34bc20fc2163f8bca7d5d87e648cfe0dd45a0cd22319d6504e9bd491a6da462ee8a3 SHA512 2d2d9e7910f18e061c5259f51510cd5e3c14c1c15b649618ea096777531780c2d5821a7bb415cd762a695302146b4835d793d31c032667431e227ac11a7aa108
+DIST grsync-1.3.1.tar.gz 302904 BLAKE2B 26bfdc0787ed3340df866f21cad79bba6ad6bb91abc834338be1dfcbe8ae464b755b4d5832586dafb416e8e88ef97a06074b5018d14ba415f625e24c66c42bef SHA512 af3e70108085ad240b8f692f4fd389e7df42448291b721e923fb7e7309e52a673a034583e68684820b47e520386c382efe56820da7b0e7146407bd3d09f2dc72
diff --git a/x11-misc/grsync/grsync-1.3.1.ebuild b/x11-misc/grsync/grsync-1.3.1.ebuild
new file mode 100644
index 000000000000..b54007c5ee03
--- /dev/null
+++ b/x11-misc/grsync/grsync-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit xdg
+
+DESCRIPTION="A gtk frontend to rsync"
+HOMEPAGE="http://www.opbyte.it/grsync/"
+SRC_URI="http://www.opbyte.it/release/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gtk3"
+
+DEPEND="
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( >=x11-libs/gtk+-2.16:2 )"
+RDEPEND="${DEPEND}
+ net-misc/rsync"
+BDEPEND="virtual/pkgconfig
+ dev-util/intltool"
+
+DOCS="AUTHORS NEWS README"
+
+src_configure() {
+ econf --disable-unity $(use_enable gtk3)
+}