summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-05 06:42:27 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-05 06:42:27 +0200
commit7e67629bddac6f9cdb8c8f843ab12785c5517f7e (patch)
tree2a5229459da039596c925364f97f0c317edfa8a2
parentdev-ruby/colored: add ruby24 (diff)
downloadgentoo-7e67629b.tar.gz
gentoo-7e67629b.tar.bz2
gentoo-7e67629b.zip
dev-ruby/nokogiri: add 1.8.0
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--dev-ruby/nokogiri/Manifest1
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.8.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/dev-ruby/nokogiri/Manifest b/dev-ruby/nokogiri/Manifest
index 20b03e3c663a..23dda66df7d8 100644
--- a/dev-ruby/nokogiri/Manifest
+++ b/dev-ruby/nokogiri/Manifest
@@ -1,3 +1,4 @@
DIST nokogiri-1.6.8.1-git.tgz 5708322 SHA256 e1d5a3bb2a0d1ee2496c1c6c89bf3e5676862af068e86b1afe34e2a781aa806f SHA512 a4546917e5979810ad4fe0f693f11f00fc719379fecefa68e36e512b128db1de083add4e80dfe3fa0546294ec68aa0f3f890575812b851e884bcbf2165f944d7 WHIRLPOOL 8a4f8c49f07f840154fc2d5087a035777fbe61717cff89d4acd1384fc945b61d012f33c756ad20bf5cc5e93d06f36868d42c217a337cddb8de7cb0fd54244116
DIST nokogiri-1.7.1-git.tgz 5712371 SHA256 3706832f06443cc1b13969bd3fe1dcc0094dca56fe16203db5f0c7e410ae8583 SHA512 82a10eff835d562a215f8a38e660f43f5d05f54fae6c6ec21cb5e4797b747be6a8eeb2e42f3c2b5710294073be8d1a987d881f7845526f0ea3ca52a0feb508d8 WHIRLPOOL 04a3124a603e1c25e61bd649dfa6b32c2e1b7e9efe0d55a3564730799926ad21c5f63ceb041fba44929a36027855cd96a4212d1b9877cd95a8c83de30c7d0ad9
DIST nokogiri-1.7.2-git.tgz 5713798 SHA256 af0a875a82abe297eb4ed020d19ee8e180bb00afa49a025cc572e0beb4323bf7 SHA512 6ab6f051304133181e50ffdd87cd07e22188841e08e52048d2f9cfaf552f98f1e7c2b84fbee0f251721735d3e25cf3e0850977d25dd256f55dc65bd05f56d740 WHIRLPOOL 147681446f78609f045e149416403181b112f634f4a2f8c3dc77d552e28e91dd74580df15b0ea1ba107d51fa43241cfc8b9fe2d4db23ece3301fa3c41dec9be3
+DIST nokogiri-1.8.0-git.tgz 5751531 SHA256 33ace509edf84a7e4271f720f8838e49ceedcc9f12e56dc2314e0984e170ef17 SHA512 a65715318e095332c3540b28eda4036321a4663ad6ffa9b7dce69a690fe6b5ab1bc9e0d1d1639a2bf426daee8c79163b5c6d78e295e27cd9bacea416895b5139 WHIRLPOOL 8b13aa4256709f2db9af40390f955fa29fae55777cefa7ae9cb194eb435b61f5f15d0472d9cc5fb6c09677b017de59a2a732397d470bae51c6c2a94da9b9f45f
diff --git a/dev-ruby/nokogiri/nokogiri-1.8.0.ebuild b/dev-ruby/nokogiri/nokogiri-1.8.0.ebuild
new file mode 100644
index 000000000000..28c709e38d40
--- /dev/null
+++ b/dev-ruby/nokogiri/nokogiri-1.8.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md ROADMAP.md STANDARD_RESPONSES.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="ext"
+
+inherit ruby-fakegem eutils multilib
+
+DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser"
+HOMEPAGE="http://nokogiri.org/"
+LICENSE="MIT"
+SRC_URI="https://github.com/sparklemotion/nokogiri/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ >=dev-libs/libxml2-2.9.2:=
+ dev-libs/libxslt
+ virtual/libiconv"
+DEPEND="${DEPEND}
+ >=dev-libs/libxml2-2.9.2
+ dev-libs/libxslt
+ virtual/libiconv"
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ >=dev-ruby/pkg-config-1.1.7
+ dev-ruby/rexical
+ dev-ruby/rdoc
+ dev-ruby/racc
+ test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/tasks\/cross_compile/s:^:#:' \
+ -e '/:test.*prerequisites/s:^:#:' \
+ -e '/license/ s:^:#:' \
+ Rakefile || die
+ # Remove the cross compilation options since they interfere with
+ # native building.
+ sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
+ sed -i -e '/cross_config_options/d' Rakefile || die
+}
+
+each_ruby_configure() {
+ NOKOGIRI_USE_SYSTEM_LIBRARIES=true \
+ ${RUBY} -Cext/${PN} extconf.rb \
+ --with-zlib-include="${EPREFIX}"/usr/include \
+ --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
+ --with-iconv-include="${EPREFIX}"/usr/include \
+ --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
+ --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
+ --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
+ --with-xslt-dir="${EPREFIX}"/usr \
+ --with-iconvlib=iconv \
+ || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
+ fi
+
+ if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
+ fi
+
+ emake -Cext/${PN} \
+ V=1 \
+ CFLAGS="${CFLAGS} -fPIC" \
+ archflag="${LDFLAGS}" || die "make extension failed"
+ cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/test_*.rb"].each {|f| require f}' || die
+}
+
+each_ruby_install() {
+ # Clean up "ext" directory before installing it. nokogumbo expects
+ # the header files and shared object to be in ext.
+ rm -rf ext/java ext/nokogiri/*.o ext/nokogiri/{mkmf.log,Makefile} || die
+
+ each_fakegem_install
+}