summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-16 16:47:57 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-16 16:53:06 +0200
commit7e815626d7b8d512e61645677d04dcdcd81997c1 (patch)
tree9d53358c026ca391e105b7528fa44be4fa1aa46b
parentnet-im/ejabberd: stabilize 23.10-r1 for amd64 (diff)
downloadgentoo-7e815626d7b8d512e61645677d04dcdcd81997c1.tar.gz
gentoo-7e815626d7b8d512e61645677d04dcdcd81997c1.tar.bz2
gentoo-7e815626d7b8d512e61645677d04dcdcd81997c1.zip
dev-python/ipython: Fix asyncio-related test failures
Closes: https://bugs.gentoo.org/928411 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ipython/ipython-8.23.0.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/ipython/ipython-8.23.0.ebuild b/dev-python/ipython/ipython-8.23.0.ebuild
index 7b1c23226c31..aa975d4a0a8f 100644
--- a/dev-python/ipython/ipython-8.23.0.ebuild
+++ b/dev-python/ipython/ipython-8.23.0.ebuild
@@ -51,6 +51,7 @@ BDEPEND="
dev-python/matplotlib-inline[${PYTHON_USEDEP}]
dev-python/pickleshare[${PYTHON_USEDEP}]
<dev-python/pytest-8[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
)
@@ -136,7 +137,8 @@ python_test() {
# nonfatal implied by virtx
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- nonfatal epytest || die "Tests failed with ${EPYTHON}"
+ nonfatal epytest -p asyncio --asyncio-mode=auto ||
+ die "Tests failed on ${EPYTHON}"
}
python_install() {