summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-29 13:24:38 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-29 13:29:01 -0600
commit7e8177dc7322dae84a7f496f545edbfd672b5c71 (patch)
tree3163b985008f3e35df8cf5a78a660f3d795fe2c0
parentapp-portage/mgorny-dev-scripts: Remove old (diff)
downloadgentoo-7e8177dc.tar.gz
gentoo-7e8177dc.tar.bz2
gentoo-7e8177dc.zip
app-containers/containerd: add 1.6.16
This version adds the ability to adjust the delay time used in start_post to conf.d/containerd. Closes: https://bugs.gentoo.org/892015 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--app-containers/containerd/Manifest1
-rw-r--r--app-containers/containerd/containerd-1.6.16.ebuild85
-rw-r--r--app-containers/containerd/files/containerd.confd3
-rw-r--r--app-containers/containerd/files/containerd.initd2
4 files changed, 90 insertions, 1 deletions
diff --git a/app-containers/containerd/Manifest b/app-containers/containerd/Manifest
index df2d51420de0..37a411b138c1 100644
--- a/app-containers/containerd/Manifest
+++ b/app-containers/containerd/Manifest
@@ -1,2 +1,3 @@
DIST containerd-1.6.14-deps.tar.xz 95727780 BLAKE2B 15782df59512ee66eacbbb65b21520edfe1ae13bf4324a7262b0731c9bf650b328c328a72cb3113d31f23ef87a74e45292a6282f8f07e79db750c1238943e203 SHA512 8db408f87924741b80b55f8e9099ab64da41021f1708ed3c156716de17dd92b2ca6cfa469b3c8d5545fbebd51f9eefcf62c57139de545762815a73eb772fbbec
DIST containerd-1.6.14.tar.gz 8698335 BLAKE2B 5f088faa35ffbcfd2e62334c12f9c741e23199d6d9999e28c69ad21b760fb85f514ef70cfdeebbdfaab914a8905ea7dae989d9fc8da36f3e077196e14dd6a220 SHA512 d29e2fb4a43f12d7e196f95b59b2c55793a1848177fb64b8bd9a4fd299fe54680a26f8a809b1d63f653ed9f0b30c209fc39d46b78ac0914d3253a10e5d3b015b
+DIST containerd-1.6.16.tar.gz 8699293 BLAKE2B ed56712ba3400c070a94b411ecff50f8c639bdbec3d55372e155dc0868e96e4285731dc5ce18deaf132696d03fc8067dbe0c41ce66ee3d675ee33f960a8ee4d3 SHA512 f10fd7d4ca1f089d0dc0044f192a8faed4c96ac589c58f969074eba299b85fca4361c74d5ef49532c34e297016ee8dab3734f315a22586fa1b8f2eb84f9f08d3
diff --git a/app-containers/containerd/containerd-1.6.16.ebuild b/app-containers/containerd/containerd-1.6.16.ebuild
new file mode 100644
index 000000000000..51f35f544572
--- /dev/null
+++ b/app-containers/containerd/containerd-1.6.16.ebuild
@@ -0,0 +1,85 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+GIT_REVISION=31aa4358a36870b21a992d3ad2bef29e1d693bec
+inherit go-module systemd
+
+DESCRIPTION="A daemon to control runC"
+HOMEPAGE="https://containerd.io/"
+SRC_URI="https://github.com/containerd/containerd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="apparmor btrfs device-mapper +cri hardened +seccomp selinux test"
+
+DEPEND="
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp )
+"
+
+# recommended version of runc is found in script/setup/runc-version
+RDEPEND="
+ ${DEPEND}
+ ~app-containers/runc-1.1.4
+"
+
+BDEPEND="
+ dev-go/go-md2man
+ virtual/pkgconfig
+"
+
+# tests require root or docker
+RESTRICT+="test"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s/-s -w//" \
+ -e "s/-mod=readonly//" \
+ Makefile || die
+ sed -i \
+ -e "s:/usr/local:/usr:" \
+ containerd.service || die
+}
+
+src_compile() {
+ local options=(
+ $(usev apparmor)
+ $(usex btrfs "" "no_btrfs")
+ $(usex cri "" "no_cri")
+ $(usex device-mapper "" "no_devmapper")
+ $(usev seccomp)
+ $(usev selinux)
+ )
+
+ myemakeargs=(
+ BUILDTAGS="${options[*]}"
+ LDFLAGS="$(usex hardened '-extldflags -fno-PIC' '')"
+ REVISION="${GIT_REVISION}"
+ VERSION=v${PV}
+ )
+
+ # race condition in man target https://bugs.gentoo.org/765100
+ # we need to explicitly specify GOFLAGS for "go run" to use vendor source
+ emake "${myemakeargs[@]}" man -j1 #nowarn
+ emake "${myemakeargs[@]}" all
+
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+ newconfd "${FILESDIR}"/${PN}.confd "${PN}"
+ newinitd "${FILESDIR}"/${PN}.initd "${PN}"
+ systemd_dounit containerd.service
+ keepdir /var/lib/containerd
+
+ # we already installed manpages, remove markdown source
+ # before installing docs directory
+ rm -r docs/man || die
+
+ local DOCS=( ADOPTERS.md README.md RELEASES.md ROADMAP.md SCOPE.md docs/. )
+ einstalldocs
+}
diff --git a/app-containers/containerd/files/containerd.confd b/app-containers/containerd/files/containerd.confd
new file mode 100644
index 000000000000..22ef83205e26
--- /dev/null
+++ b/app-containers/containerd/files/containerd.confd
@@ -0,0 +1,3 @@
+# This is the delay to be used in the start_post function to wait for
+# the socket to be active.
+#containerd_socket_delay=5
diff --git a/app-containers/containerd/files/containerd.initd b/app-containers/containerd/files/containerd.initd
index 6536fc9ef209..143305c03336 100644
--- a/app-containers/containerd/files/containerd.initd
+++ b/app-containers/containerd/files/containerd.initd
@@ -22,5 +22,5 @@ start_pre() {
}
start_post() {
- ewaitfile 5 /run/containerd/containerd.sock
+ ewaitfile ${containerd_socket_delay:-5} /run/containerd/containerd.sock
}