summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-30 05:16:19 +0000
committerSam James <sam@gentoo.org>2021-01-30 05:16:19 +0000
commit7e8223ef7dcb6ad38c5fe5f8505e0e36ac75c56d (patch)
tree625ddc3bbcde500efe013a2dcca584cd95886492
parentmedia-libs/codec2: remove unused patch(es) (diff)
downloadgentoo-7e8223ef7dcb6ad38c5fe5f8505e0e36ac75c56d.tar.gz
gentoo-7e8223ef7dcb6ad38c5fe5f8505e0e36ac75c56d.tar.bz2
gentoo-7e8223ef7dcb6ad38c5fe5f8505e0e36ac75c56d.zip
dev-libs/libtommath: fix Darwin install
Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/libtommath/libtommath-1.2.0.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-libs/libtommath/libtommath-1.2.0.ebuild b/dev-libs/libtommath/libtommath-1.2.0.ebuild
index 78def9854c3f..56b357a35051 100644
--- a/dev-libs/libtommath/libtommath-1.2.0.ebuild
+++ b/dev-libs/libtommath/libtommath-1.2.0.ebuild
@@ -65,6 +65,11 @@ src_test() {
src_install() {
_emake -f makefile.shared install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ local path="usr/$(get_libdir)/libtommath.${PV}.dylib"
+ install_name_tool -id "${EPREFIX}/${path}" "${ED}/${path}" || die "Failed to adjust install_name"
+ fi
+
# We only link against -lc, so drop the .la file.
find "${ED}" -name '*.la' -delete || die
if ! use static-libs ; then