summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-07-02 18:17:56 +0100
committerMarek Szuba <marecki@gentoo.org>2021-07-02 19:31:16 +0100
commit7e98b43f9cb33b3513010de9240d2b5f229fb8a9 (patch)
tree81c7015eeee7306b908c0b6c8353d672734864de
parentsys-devel/llvm-roc: Remove unncessary dep on virtual/cblas (diff)
downloadgentoo-7e98b43f.tar.gz
gentoo-7e98b43f.tar.bz2
gentoo-7e98b43f.zip
dev-util/ltrace: add 0.7.3.6.1
Debian now uses two-part version numbers for their changes in this package, which is not allowed with _p in Gentoo - so just extend the standard version number by two more parts, it's unlikely this will conflict with the upstream scheme even if they even do release a new version. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-util/ltrace/Manifest1
-rw-r--r--dev-util/ltrace/ltrace-0.7.3.6.1.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-util/ltrace/Manifest b/dev-util/ltrace/Manifest
index 7fc0116aba03..d5af7e1c9ff5 100644
--- a/dev-util/ltrace/Manifest
+++ b/dev-util/ltrace/Manifest
@@ -1,2 +1,3 @@
DIST ltrace_0.7.3-4.debian.tar.gz 11373 BLAKE2B 3004bef4e0181e28606e1c50dcc2265d9869e51bf11288185da46f7a77a0aaffb41af75f84baa7d094f9f752071c9e8f53c565982a955e3250a7fc721c529b20 SHA512 67a868c95703ca9cd8407905e3be416e3a66920f41d9deb78fadb71719d7d3f1a3f67ffcb575acff4bf7e4715102f3a6b0f67c6adb74f37ee66c398c132ff04b
+DIST ltrace_0.7.3-6.1.debian.tar.xz 11404 BLAKE2B d38ce51dfcbf809d7622029fb6dd0acd61c8d8213be0bf2625fd746adbe6dd6830faf208b7e864c1185013d7d5e17f3e10e8a8fb45f8e0a4bc9859fde96a55d7 SHA512 c0753935d74be530886ce5202429cabbbe73814c9ac120eaf90a1c4e03dfd4de5381e3e85a27fbbbce694b23cd72a273199575419446b6159b0925d85e1938ab
DIST ltrace_0.7.3.orig.tar.bz2 482658 BLAKE2B 30d1dbb178a41043e4bbbac17a23676db202b64327c9bb4393ae7ace9f5e1a1e2a5ded56cabc7faf2ea55b22ed17126a94c121147aeefb40250710b7307a50d3 SHA512 a842b16dcb81da869afa0bddc755fdff0d57b35672505bf2c7164fd983b1938d28b126714128930994cc1230ced69d779456d0cfc16f4008c9b6d19f0852285d
diff --git a/dev-util/ltrace/ltrace-0.7.3.6.1.ebuild b/dev-util/ltrace/ltrace-0.7.3.6.1.ebuild
new file mode 100644
index 000000000000..9fd7b01b8545
--- /dev/null
+++ b/dev-util/ltrace/ltrace-0.7.3.6.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+LTRACE_V=$(ver_cut 1-3)
+DB_V=$(ver_cut 4-5)
+
+DESCRIPTION="trace library calls made at runtime"
+HOMEPAGE="https://gitlab.com/cespedes/ltrace"
+SRC_URI="
+ mirror://debian/pool/main/l/${PN}/${PN}_${LTRACE_V}.orig.tar.bz2
+ mirror://debian/pool/main/l/${PN}/${PN}_${LTRACE_V}-${DB_V}.debian.tar.xz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug selinux test unwind"
+
+RDEPEND="virtual/libelf:=
+ selinux? ( sys-libs/libselinux )
+ unwind? ( sys-libs/libunwind:= )"
+DEPEND="${RDEPEND}
+ sys-libs/binutils-libs
+ test? ( dev-util/dejagnu )"
+
+# under musl tests need major work upstream, half of them does not work.
+RESTRICT="
+ !test? ( test )
+ elibc_musl? ( test )
+"
+
+S=${WORKDIR}/${PN}-${LTRACE_V}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.3-test-protos.patch #bug 421649
+ "${FILESDIR}"/${PN}-0.7.3-alpha-protos.patch
+ "${FILESDIR}"/${PN}-0.7.3-ia64.patch
+ "${FILESDIR}"/${PN}-0.7.3-print-test-pie.patch
+ "${FILESDIR}"/${PN}-0.7.3-ia64-pid_t.patch
+ "${FILESDIR}"/${PN}-0.7.3-musl-host.patch #713428
+ "${FILESDIR}"/${PN}-0.7.3-no-error.h.patch #713428
+ "${FILESDIR}"/${PN}-0.7.3-no-error.h-2.patch #713428
+ "${FILESDIR}"/${PN}-0.7.3-no-REG_NOERROR.patch #713428
+ "${FILESDIR}"/${PN}-0.7.3-pid_t.patch #713428
+ "${FILESDIR}"/${PN}-0.7.3-tuple-tests.patch
+ "${FILESDIR}"/${PN}-0.7.3-CXX-for-tests.patch
+ "${FILESDIR}"/${PN}-0.7.3-test-glibc-2.33.patch
+ "${FILESDIR}"/${PN}-0.7.3-disable-munmap-test.patch
+)
+
+src_prepare() {
+ eapply "${WORKDIR}"/debian/patches/[0-9]*
+
+ default
+
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ ac_cv_header_selinux_selinux_h=$(usex selinux) \
+ ac_cv_lib_selinux_security_get_boolean_active=$(usex selinux) \
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with unwind libunwind)
+}
+
+src_test() {
+ # sandbox redirects vfork() to fork(): bug # 774054
+ # Let's avoid sandbox entirely.
+ SANDBOX_ON=0 LD_PRELOAD= emake check
+}