summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:14:25 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:28 +0000
commit7e98e8c28891a994738be4734f468d9bb1fb1d0b (patch)
tree1c19e9590cfb6641757982594e372d153c388612
parentsys-apps/ifd-gempc: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-7e98e8c28891a994738be4734f468d9bb1fb1d0b.tar.gz
gentoo-7e98e8c28891a994738be4734f468d9bb1fb1d0b.tar.bz2
gentoo-7e98e8c28891a994738be4734f468d9bb1fb1d0b.zip
sys-apps/minijail: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-apps/minijail/minijail-9.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-apps/minijail/minijail-9.ebuild b/sys-apps/minijail/minijail-9.ebuild
index a11b63da62ab..bca6a4432644 100644
--- a/sys-apps/minijail/minijail-9.ebuild
+++ b/sys-apps/minijail/minijail-9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -40,8 +40,8 @@ src_configure() {
export LIBDIR="/usr/$(get_libdir)"
export USE_seccomp="$(usex seccomp)"
export USE_SYSTEM_GTEST=yes
- export GTEST_CXXFLAGS="$(pkg-config --cflags gtest_main)"
- export GTEST_LIBS="$(pkg-config --libs gtest_main)"
+ export GTEST_CXXFLAGS="$($(tc-getPKG_CONFIG) --cflags gtest_main)"
+ export GTEST_LIBS="$($(tc-getPKG_CONFIG) --libs gtest_main)"
}
src_compile() {