summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-14 22:33:21 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-14 22:36:24 -0400
commit7ead9e6cae97ae4f00d419d49095ff34b8741fa7 (patch)
treead6ecd4995241d2a6db582fecb9c9e67b44f8925
parentx11-terms/kitty-shell-integration: add 0.34.0 (diff)
downloadgentoo-7ead9e6cae97ae4f00d419d49095ff34b8741fa7.tar.gz
gentoo-7ead9e6cae97ae4f00d419d49095ff34b8741fa7.tar.bz2
gentoo-7ead9e6cae97ae4f00d419d49095ff34b8741fa7.zip
x11-terms/kitty-terminfo: add 0.34.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.34.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 647fa679fd7b..8922d7b2e08b 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.32.2.tar.xz 8103024 BLAKE2B 637449eb655973700493f725846263bfba193729725b6f14490fc44872e191c5e47b272bc3955b5ca47d400a497931be0749d338354ae8a5402fd867f7b941d3 SHA512 245d399366c0b2174bb80d557c08edf49e96a034a3cf33d2027180ef418581cc9bea2566d9ead9f96094bdc01655aeddd251b07b1bc444e7af59c864eb2bcd01
DIST kitty-0.33.1.tar.xz 8166164 BLAKE2B 6592ae99f3e05bda5367186096804175f00f21770e7112bf45fa968d161e70d2fdcf956214e29e048e6973ee14457f5eaca753a761824f1c104ba32552122e33 SHA512 5fa2421baf9fac41d4a8ff89bb5e44d1820012e8c960e25980d597dcebbb44ffa97c03818e8a91015691321eedb9d9f53139a97cbb6bd673053fbfd73c77739b
+DIST kitty-0.34.0.tar.xz 8227440 BLAKE2B 8e5b27d095a73711995f5f9c7b320e13632893ae3040204d643e5fe29a98c0337aff3abd4aa91300c84fa8fc435a077beddbbec123937b6db29a2c2f3fb1e89c SHA512 310084af59fb5832c9b87961d278601a8408fdcf4500083ffa5d4980ae600a2122a7477be23bfe0c374dec7955707894cb74cfd550ae577d66e39ed2e8b9c0f8
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.34.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.34.0.ebuild
new file mode 100644
index 000000000000..b5c7cbc40759
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.34.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}