summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Kustov <ktrace@yandex.ru>2021-06-08 16:23:16 +0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-16 19:50:54 +0200
commit7eb9aaa9b4a7155b612eed02f5373415879944b1 (patch)
tree1f55f2e03473ccc13c14534906510fa3ecf3d571
parentsci-astronomy/wcslib: verbump to 7.4 (diff)
downloadgentoo-7eb9aaa9b4a7155b612eed02f5373415879944b1.tar.gz
gentoo-7eb9aaa9b4a7155b612eed02f5373415879944b1.tar.bz2
gentoo-7eb9aaa9b4a7155b612eed02f5373415879944b1.zip
sci-electronics/xcircuit: version bump to 3.10.20
- up version to 3.10.30 - add ngspice as run dependency Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Victor Kustov <ktrace@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/21161 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-electronics/xcircuit/Manifest1
-rw-r--r--sci-electronics/xcircuit/xcircuit-3.10.30.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sci-electronics/xcircuit/Manifest b/sci-electronics/xcircuit/Manifest
index d35a7325e092..081de064ba6a 100644
--- a/sci-electronics/xcircuit/Manifest
+++ b/sci-electronics/xcircuit/Manifest
@@ -1 +1,2 @@
+DIST xcircuit-3.10.30.tgz 1619256 BLAKE2B 5316a2dc7d9864eefbdbf1647920c322c85adfbe27289a7c4dfc719940921754a6e616af530b20b3ffa159004ce6808cceb6e4d9349dcbc110e2e580a574c7a1 SHA512 52bf65fa9b5c095092f60abe32b3c88180365cc8043a8e95652ea9ab20e01c3e790989fe41171ecd1b2c60684016f6963c4851105b17a1c8a3bac8d75db84a8e
DIST xcircuit-3.9.73.tgz 1620922 BLAKE2B ac3f8e6f9370efd720b57a9cd7c487621534f477d1af4fd267d311da3bd949886eccd1c8e8e59071689637272ca23f985dd1809594aab692fa60ea2ca8f8a456 SHA512 2dfeb130a48c99bf08bdff94250f7157acd283bc3f3d6b41f963346deb1241aca0d59a3e8d60dbd36a4aa60acd89e131b263ddbf489b2b44e7e1831714d7b703
diff --git a/sci-electronics/xcircuit/xcircuit-3.10.30.ebuild b/sci-electronics/xcircuit/xcircuit-3.10.30.ebuild
new file mode 100644
index 000000000000..838248386668
--- /dev/null
+++ b/sci-electronics/xcircuit/xcircuit-3.10.30.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Circuit drawing and schematic capture program"
+SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
+HOMEPAGE="http://opencircuitdesign.com/xcircuit"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="tcl"
+
+DEPEND="
+ app-text/ghostscript-gpl
+ media-libs/fontconfig:1.0=
+ sys-libs/zlib:=
+ x11-libs/cairo
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt
+ tcl? (
+ dev-lang/tcl:0=
+ dev-lang/tk:0=
+ )
+"
+RDEPEND="${DEPEND}
+ sci-electronics/ngspice"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-cairo
+ --with-ngspice
+ $(use_with tcl)
+ $(use_with tcl tcllibs "/usr/$(get_libdir)")
+ $(use_with tcl tk)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}