summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:57:03 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:07 +0100
commit7eecfaa183560e055a588fa3479281d22c464886 (patch)
tree3269a268cf24e07eec5559ffcd749ba1d9e37df6
parentnet-mail/fetchmail: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-7eecfaa1.tar.gz
gentoo-7eecfaa1.tar.bz2
gentoo-7eecfaa1.zip
net-misc/asterisk: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-misc/asterisk/asterisk-13.38.3.ebuild2
-rw-r--r--net-misc/asterisk/asterisk-16.19.1.ebuild2
-rw-r--r--net-misc/asterisk/asterisk-18.5.1.ebuild2
3 files changed, 6 insertions, 0 deletions
diff --git a/net-misc/asterisk/asterisk-13.38.3.ebuild b/net-misc/asterisk/asterisk-13.38.3.ebuild
index 400218a388d5..f20b32b8542d 100644
--- a/net-misc/asterisk/asterisk-13.38.3.ebuild
+++ b/net-misc/asterisk/asterisk-13.38.3.ebuild
@@ -322,6 +322,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process asterisk.conf
+
if [ -z "${REPLACING_VERSIONS}" ]; then
elog "Asterisk Wiki: https://wiki.asterisk.org/wiki/"
elog "Gentoo VoIP IRC Channel: #gentoo-voip @ irc.libera.chat"
diff --git a/net-misc/asterisk/asterisk-16.19.1.ebuild b/net-misc/asterisk/asterisk-16.19.1.ebuild
index 10706b53e507..77e488e7b79a 100644
--- a/net-misc/asterisk/asterisk-16.19.1.ebuild
+++ b/net-misc/asterisk/asterisk-16.19.1.ebuild
@@ -331,6 +331,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process asterisk.conf
+
if [ -z "${REPLACING_VERSIONS}" ]; then
elog "Asterisk Wiki: https://wiki.asterisk.org/wiki/"
elog "Gentoo VoIP IRC Channel: #gentoo-voip @ irc.libera.chat"
diff --git a/net-misc/asterisk/asterisk-18.5.1.ebuild b/net-misc/asterisk/asterisk-18.5.1.ebuild
index 1334c613ae61..e3f72db7541b 100644
--- a/net-misc/asterisk/asterisk-18.5.1.ebuild
+++ b/net-misc/asterisk/asterisk-18.5.1.ebuild
@@ -330,6 +330,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process asterisk.conf
+
if [ -z "${REPLACING_VERSIONS}" ]; then
elog "Asterisk Wiki: https://wiki.asterisk.org/wiki/"
elog "Gentoo VoIP IRC Channel: #gentoo-voip @ irc.libera.chat"