summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-12-18 15:12:08 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-12-18 15:14:07 +0100
commit7f05d540bf2d571619d630d375c6ca5eff14cdaa (patch)
tree1220f00bb0c41f24cba6c5cd08fd50b922bb586c
parentdev-python/memory_profiler: add 0.60 (diff)
downloadgentoo-7f05d540bf2d571619d630d375c6ca5eff14cdaa.tar.gz
gentoo-7f05d540bf2d571619d630d375c6ca5eff14cdaa.tar.bz2
gentoo-7f05d540bf2d571619d630d375c6ca5eff14cdaa.zip
app-editors/nano: Bump to version 6.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-editors/nano/Manifest1
-rw-r--r--app-editors/nano/files/gentoo.nanorc74
-rw-r--r--app-editors/nano/nano-6.0.ebuild93
3 files changed, 168 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 8b3194b5ca78..037fbe1c759f 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,2 +1,3 @@
DIST nano-5.8.tar.gz 3038948 BLAKE2B 126976539e8ab3a7be986edc7422bc58d31e0c81dffbf34c9b701d09d268233ed0de4f07ac8d2dd0963b768cce4e2afe89a4f8ed9fd216a71ebac98c7f403deb SHA512 dd3a7e328f256052707c4d28f2ca32f9e44de123e3dee3c0747fbab222d215b2a895c403b9274fd286e19477b8be3314fc83167eec32194370105b1e70c05a3f
DIST nano-5.9.tar.gz 3093675 BLAKE2B d4fa2f0e64b6ab243a2b127ff894e900098f6261f5d46657ff3459cc0b51683a63fc5de54bd4545b47bc16c633b09142f8501b84a09df3e8123da5233a063766 SHA512 61bf4de300579bc6f0028a2237e105228d8657819c02f32c7ef8f84f9c54734df8fb9a9cddbce0f7721ebc5ac8ae4799c118291ae15480082f8b1317019a485d
+DIST nano-6.0.tar.gz 3114631 BLAKE2B d89abcbd3673867447bbfd4eedfcd7b7d5250a3ebc1048068cf03f690b2fbd072c0224c00bef9b829bff8343dacf669e8e784fa24dafaa6441746471b692c55a SHA512 fa5726810cfb53fd2cc451d5a34e8f5c316c496f8d649a3899fae0b61cc5ca0bffd28deb780e4e0c98169487b8c34468fd401534b9110ba968d2d4ab6847bc87
diff --git a/app-editors/nano/files/gentoo.nanorc b/app-editors/nano/files/gentoo.nanorc
new file mode 100644
index 000000000000..84e9bcf28ebf
--- /dev/null
+++ b/app-editors/nano/files/gentoo.nanorc
@@ -0,0 +1,74 @@
+## Syntax highlighting for Gentoo ebuilds/eclasses,
+## and (further down) for Portage control files.
+
+syntax ebuild "\.e(build|class)$"
+comment "#"
+
+## All the standard portage functions:
+color brightgreen "(^|\<default_)src_(unpack|prepare|configure|compile|install|test)\>"
+color brightgreen "^pkg_(config|nofetch|info|pretend|setup|(pre|post)(inst|rm))\>"
+color brightgreen "\<default(_pkg_nofetch|_src_(unpack|prepare|configure|compile|test))?\>"
+## Bash-related syntax:
+color green "\<(break|case|continue|do|done|elif|else|esac|exit|fi|for|function|if|in|read|return|select|shift|then|time|until|while)\>"
+color green "\<(declare|eval|exec|export|let|local)\>"
+color green "[][{}():;|`$<>!=&\]"
+color green "-[defhnrsuwxzL]\>"
+color green "-(eq|ne|gt|lt|ge|le)\>"
+## Variables... official portage ones in red, all others in bright red:
+color brightred "\$[-0-9@*#?$!]" "\$[[:alpha:]_][[:alnum:]_]*"
+color brightred "\$\{[#!]?([-@*#?$!]|[0-9]+|[[:alpha:]_][[:alnum:]_]*)(\[([[:digit:]]|@)+\])?(([#%/]|:?[-=?+])[^}]*\}|\[|\})"
+color red "\<(EAPI|ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|[BIPR]?DEPEND|PROVIDE|PROPERTIES|REQUIRED_USE|RESTRICT|USERLAND)\>"
+color red "\<(S|E?D|T|PV|PF|P|PN|PR|PVR|A|CATEGORY|DISTDIR|FILESDIR|EPREFIX|(B|E|E?SYS)?ROOT|WORKDIR)\>"
+color red "\<(AS|C(PP|XX)?|LD)FLAGS\>" "\<C(HOST|TARGET|BUILD)\>" "\<(MERGE_TYPE|REPLACING_VERSIONS|REPLACED_BY_VERSION)\>"
+color red "\<EBUILD_PHASE(_FUNC)?\>"
+color red "\<QA_((TEXTRELS|EXECSTACK|WX_LOAD)(_[a-zA-Z_0-9]+)?|DT_HASH|PRESTRIPPED)\>"
+color red "\<(PATCHES|(HTML_)?DOCS)\>" "\<WANT_(AUTO(CONF|MAKE)|LIBTOOL)\>" "\<AT_M4DIR\>"
+## Portage commands:
+color magenta "\<(use(_(with|enable|if_iuse)|x)?|in_iuse) [!a-zA-Z0-9_+ -]*" "inherit.*"
+color brightblue "\<e(apply(_user)?|begin|end|conf|install|make|ninja|qmake5|ant|(qa)?warn|infon?|error|log|patch(_user)?|new(group|user))\>"
+color brightblue "\<e(pause|beep|mktemp|(cvs|svn)_clean|punt_cxx)\>" "\<e(aclocal|auto(reconf|header|conf|make)|libtoolize)\>"
+color brightblue "\<e(stack|shopts|umask)_(push|pop)\>" "\<get_libdir\>" "\<ver_(cut|rs|test)\>" "\<version_is_at_least\>"
+color brightblue "\<make_desktop_entry\>" "\<unpack(_(makeself|pdv))?\>"
+color brightblue "\<(die|hasv?|inherit|nonfatal)\>" "\<(use(_(with|enable|if_iuse)|x)?|in_iuse)\>" "\<(has|best)_version\>"
+color brightblue "\<(do|new)(ins|s?bin|doc|header|lib(\.so|\.a)?|man|info|exe|initd|confd|envd|pam|menu|icon)\>"
+color brightblue "\<do(compress|dir|html|mo|strip|sym)\>" "\<keepdir\>"
+color brightblue "\<prepall(docs|info|man|strip)?\>" "\<prep(info|lib|lib\.(so|a)|man|strip)\>"
+color brightblue "\<(doc|ins|exe)?into\>" "\<f(owners|perms)\>" "\<(exe|ins|dir)opts\>"
+color brightblue "\<tc-get(BUILD_)?(AR|AS|CC|CPP|CXX|LD|NM|OBJCOPY|PKG_CONFIG|RANLIB)\>"
+color brightblue "\<tc-(arch(-kernel)?|export|has-(tls|openmp)|is-cross-compiler)\>"
+## Common commands used in ebuilds:
+color blue "\<(awk|cat|cd|chmod|chown|cp|echo|env|find|e?grep|ln|make|mkdir|mv|popd|printf|pushd|rm|rmdir|sed|set|tar|touch|unset|xargs)\>"
+## Comments (doesn't work that well):
+color yellow "(^|[[:space:]])#.*"
+## Strings (doesn't work that well):
+color brightyellow ""([^"\]|\\.)*"|'([^'\]|\\.)*'"
+## Trailing space is bad!
+color ,green "[[:space:]]+$"
+## Mixed whitespace is also bad.
+color ,green " "
+
+
+syntax /etc/portage "\.(accept_keywords|env|keywords|mask|unmask|use)(/.+)?$"
+comment "#"
+
+## Base text:
+color green ".+"
+## Likely version and slot numbers:
+color magenta "-[[:digit:].]+(_(alpha|beta|pre|rc|p)[[:digit:]]*)*(-r[[:digit:]]+)?([:[:space:]]|$)"
+color magenta ":[^[:space:]]+([[:space:]]|$)"
+## Use flags (must come after version/slot):
+color brightred "[[:space:]]+\+?[A-Za-z0-9+_@-]+"
+color brightblue "[[:space:]]+-[A-Za-z0-9+_@-]+"
+## Accepted arches:
+color white "[~-]?\<(alpha|amd64|arm(64)?|hppa|ia64|m68k|mips|ppc(64)?|riscv|s390|sparc|x86)(-(cygwin|linux|macos|solaris|winnt))?\>"
+color white "[[:space:]][*~-]?\*"
+## Categories:
+color cyan "^[[:space:]]*[^/]*/"
+## Masking regulators:
+color brightmagenta "^[[:space:]]*(=|~|<|<=|>|>=)"
+## Comments:
+color yellow "#.*"
+## Trailing space is bad!
+color ,green "[[:space:]]+$"
+## Mixed whitespace is also bad.
+color ,green " "
diff --git a/app-editors/nano/nano-6.0.ebuild b/app-editors/nano/nano-6.0.ebuild
new file mode 100644
index 000000000000..ad20434b2ed1
--- /dev/null
+++ b/app-editors/nano/nano-6.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
+ inherit git-r3 autotools
+else
+ MY_P="${PN}-${PV/_}"
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug justify magic minimal ncurses nls +spell +split-usr static unicode"
+
+LIB_DEPEND="
+ >=sys-libs/ncurses-5.9-r1:=[unicode(+)?]
+ sys-libs/ncurses:=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="${RDEPEND}
+ static? ( ${LIB_DEPEND} )"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="
+ magic? ( !minimal )
+"
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir=/trash
+ $(use_enable !minimal color)
+ $(use_enable !minimal multibuffer)
+ $(use_enable !minimal nanorc)
+ $(use_enable magic libmagic)
+ $(use_enable spell speller)
+ $(use_enable justify)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable unicode utf8)
+ $(use_enable minimal tiny)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ # don't use "${ED}" here or things break (#654534)
+ rm -r "${D}"/trash || die
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED}"/etc/nanorc || die
+
+ # Since nano-5.0 these are no longer being "enabled" by default
+ # (bug #736848)
+ local rcdir="/usr/share/nano"
+ mv "${ED}"${rcdir}/extra/* "${ED}"/${rcdir}/ || die
+ rmdir "${ED}"${rcdir}/extra || die
+
+ insinto "${rcdir}"
+ doins "${FILESDIR}/gentoo.nanorc"
+ fi
+
+ use split-usr && dosym ../../bin/nano /usr/bin/nano
+}