summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-02 03:00:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-02 03:37:05 +0200
commit7f09fa144d563a6ddee5e0620a0649ded2f82b88 (patch)
treefaa87600ff15b6649a773e1cc63ced03d8d6333d
parentdev-python/boto3: Bump to 1.34.96 (diff)
downloadgentoo-7f09fa144d563a6ddee5e0620a0649ded2f82b88.tar.gz
gentoo-7f09fa144d563a6ddee5e0620a0649ded2f82b88.tar.bz2
gentoo-7f09fa144d563a6ddee5e0620a0649ded2f82b88.zip
app-admin/awscli: Bump to 1.32.96
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.96.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index aaee59a3df73..e0e5fed2f2e0 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.32.88.gh.tar.gz 2693435 BLAKE2B 043f4eb08711760b7f8e15a5eba879524
DIST aws-cli-1.32.93.gh.tar.gz 2695489 BLAKE2B d2f81786d4db158a13ec50ed833668db26bde00cc1e4f5254aa127aba82113074abafa996f525b5f7cd215fd51639481a01a49c425bb4c01e990261529f06082 SHA512 e03892ef522fa43442d1b053d0bf8dbd6c892d94398934c4af58e81153c2759f7e55a289457bb3e5b46f2f01697642498fdd6d51cdc18ad8b6c0f6a31d7c606a
DIST aws-cli-1.32.94.gh.tar.gz 2696222 BLAKE2B 275464cb94d3282141209aa1ba90bd5a4a69f128f55cf222f60e8b964126d8bbc63c5313034496b18bb2db7c9ccba2ac199345e3f93e8597feded89a05f59df5 SHA512 a4fb1667d9161ffab2165502bc89a93667f83bcdae778daf42b4675b9345d0a497f5b36c40cf758613e8e4443173d4d358d39e6e30196c9f5a6b8a102d45c366
DIST aws-cli-1.32.95.gh.tar.gz 2699193 BLAKE2B d50c00be87343f80be4342f6f1ef6ac611c6c7c37d72e369b87aff0d38ed763451a3de54a7d4013632f47cebd688b76b9103e85a20e58e01cd5ee66e7eabeb20 SHA512 0ec08479e9ef3b0eb231438c59379beb2d6a8bdca52a375bc5ba386d2bde3062093bb592bbf843d2be80658d9d88d4ae71ffa372db1261d6f6f16cd17c196ddc
+DIST aws-cli-1.32.96.gh.tar.gz 2699395 BLAKE2B 7d778ad8886b8416e3c99a639d2923fedfe4154d19e3d8c064f8261f99e586f79a10a174a731ba647c51805baf9f135ea71f6ef766de791bae18b83b80294a74 SHA512 2f02afea5a04960b94101596b55ddd8461344e2d6ac8e5023c05363f052e32ec2076727e080c1cbad8c37c90266ec57572cc41809993b6b4f5fa81c909cb75aa
diff --git a/app-admin/awscli/awscli-1.32.96.ebuild b/app-admin/awscli/awscli-1.32.96.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.96.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}