summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-05 21:48:42 +0100
committerSam James <sam@gentoo.org>2021-04-05 21:48:42 +0100
commit7f274e08fe0aa3329a72177dbebc1932dbd4bffa (patch)
treef23f4621c4078fedd2d492d5c837bef7d91f0513
parentx11-libs/libSM: add sys-libs/native-uuid dep on Darwin (diff)
downloadgentoo-7f274e08.tar.gz
gentoo-7f274e08.tar.bz2
gentoo-7f274e08.zip
sys-devel/slibtool: add 0.5.33
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-devel/slibtool/Manifest1
-rw-r--r--sys-devel/slibtool/slibtool-0.5.33.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sys-devel/slibtool/Manifest b/sys-devel/slibtool/Manifest
index e7c922786331..8705f308e0f5 100644
--- a/sys-devel/slibtool/Manifest
+++ b/sys-devel/slibtool/Manifest
@@ -1,2 +1,3 @@
DIST slibtool-0.5.31.tar.xz 70008 BLAKE2B aa46b2bfe02e22dabb3dc56b2de9521ef8fd3b54774561bcccca15763c8ee88154a03bb6defd4f6b828eaadb040e66725d18b788aac0a4d0170ce02cb044e9eb SHA512 658ea3244c6d1e9bd389ea5c222c29df6ba7acc5d6f2ada7a94dd3ac29ffbb681f377d8887a99861ab2ab484a7d3551e020bac2b92bdb07ad0e9ee96facfc6bd
DIST slibtool-0.5.32.tar.xz 72820 BLAKE2B 2098af643b9591d85a9fa2d34c4a0c06af664786acd15f26ebebe966d4fbac2085fa8525cdb28d7087bd59e16334f793bbb87ada7011572a8ac7ada0ca5ab770 SHA512 60c6bb8cd2e49d5a417b61c96b81fd25534bc9915d8b3db0078ae6469685591997a503fcabb0cf1b336f883e61c32892dc9d39d69b4041ef9d49d6cd52f760a5
+DIST slibtool-0.5.33.tar.xz 74100 BLAKE2B ae4901fb116c1c9463d7a817dc0c3aff2de0983b19d0ca84d5081aa4ac0f6b7a386ccf4cc3916c799ecc8d053a1b8dd71f7f8aafeae358d3931ce4ebc68932e0 SHA512 d4fd15669f8792a09f162f124ff92544efbc0e963b0ed5e8b9f3521f8da204380c6d9f175cfac818e769d5e90ae5d52eddfccdecf82880c11083997dca676ae4
diff --git a/sys-devel/slibtool/slibtool-0.5.33.ebuild b/sys-devel/slibtool/slibtool-0.5.33.ebuild
new file mode 100644
index 000000000000..515a39ae78f4
--- /dev/null
+++ b/sys-devel/slibtool/slibtool-0.5.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+# git.foss21.org is the official repository per upstream
+DESCRIPTION="A skinny libtool implementation, written in C"
+HOMEPAGE="https://git.foss21.org/slibtool"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.foss21.org/slibtool"
+else
+ SRC_URI="https://dl.midipix.org/slibtool/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_configure() {
+ # Custom configure script (not generated by autoconf)
+ ./configure \
+ --compiler=$(tc-getCC) \
+ --host=${CHOST} \
+ --prefix="${EPREFIX}"/usr \
+ || die
+}